summaryrefslogtreecommitdiff
path: root/sys-libs/db/db-4.8.30-r8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/db/db-4.8.30-r8.ebuild')
-rw-r--r--sys-libs/db/db-4.8.30-r8.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-libs/db/db-4.8.30-r8.ebuild b/sys-libs/db/db-4.8.30-r8.ebuild
index f5906a0c970e..7d3883eeb360 100644
--- a/sys-libs/db/db-4.8.30-r8.ebuild
+++ b/sys-libs/db/db-4.8.30-r8.ebuild
@@ -80,6 +80,12 @@ src_prepare() {
-i configure || die
}
+src_configure() {
+ # Force bfd before calling multilib_toolchain_setup
+ tc-ld-force-bfd #470634 #729510
+ multilib-minimal_src_configure
+}
+
multilib_src_configure() {
local myconf=(
--enable-compat185
@@ -93,9 +99,6 @@ multilib_src_configure() {
$(use_enable test)
)
- # bug #470634 and bug #729510
- tc-ld-force-bfd
-
# compilation with -O0 fails on amd64, see bug #171231
if [[ ${ABI} == amd64 ]]; then
local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}