summaryrefslogtreecommitdiff
path: root/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild b/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
index 6efc90216769..241fc11bd3ac 100644
--- a/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
@@ -19,14 +19,14 @@ SLOT="${PV%_*}"
KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="+clang test"
-LLVM_SLOT=${SLOT%%.*}
+LLVM_MAX_SLOT=${SLOT%%.*}
# llvm-4 needed for --cmakedir
DEPEND="
>=sys-devel/llvm-4
clang? ( sys-devel/clang )
test? (
- $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]")
- =sys-devel/clang-${PV%_*}*:${LLVM_SLOT} )
+ $(python_gen_any_dep "dev-python/lit[\${PYTHON_USEDEP}]")
+ =sys-devel/clang-${PV%_*}*:${LLVM_MAX_SLOT} )
${PYTHON_DEPS}"
S=${WORKDIR}/${P/_/}.src
@@ -88,8 +88,8 @@ src_configure() {
mycmakeargs+=(
-DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
- -DCOMPILER_RT_TEST_COMPILER="${EPREFIX}/usr/lib/llvm/${LLVM_SLOT}/bin/clang"
- -DCOMPILER_RT_TEST_CXX_COMPILER="${EPREFIX}/usr/lib/llvm/${LLVM_SLOT}/bin/clang++"
+ -DCOMPILER_RT_TEST_COMPILER="${EPREFIX}/usr/lib/llvm/${LLVM_MAX_SLOT}/bin/clang"
+ -DCOMPILER_RT_TEST_CXX_COMPILER="${EPREFIX}/usr/lib/llvm/${LLVM_MAX_SLOT}/bin/clang++"
)
fi