summaryrefslogtreecommitdiff
path: root/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
index a3954df9f7dc..92894146cb09 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
-IUSE="+clang test"
+IUSE="+clang debug test"
RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}
@@ -60,6 +60,9 @@ test_compiler() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
# pre-set since we need to pass it to cmake
BUILD_DIR=${WORKDIR}/${P}_build