summaryrefslogtreecommitdiff
path: root/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.95.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/vanilla-kernel/vanilla-kernel-4.19.95.ebuild')
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-4.19.95.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.95.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.95.ebuild
deleted file mode 100644
index 03ea40f919c4..000000000000
--- a/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.95.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit kernel-build
-
-MY_P=linux-${PV}
-# https://git.archlinux.org/svntogit/packages.git/log/trunk/config?h=packages/linux-lts
-AMD64_CONFIG_VER=4.19.92-arch1
-AMD64_CONFIG_HASH=bf97de6a2e405659aaad4c251b7f0bb48d5ed3c9
-# https://git.archlinux32.org/packages/log/core/linux-lts/config
-I686_CONFIG_VER=4.19.85-arch1
-I686_CONFIG_HASH=1f0345e2983d2edd55b401cb5a87fdf365a4192c
-
-DESCRIPTION="Linux kernel built from vanilla upstream sources"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
- amd64? (
- https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux-lts&id=${AMD64_CONFIG_HASH}
- -> linux-${AMD64_CONFIG_VER}.amd64.config
- )
- x86? (
- https://git.archlinux32.org/packages/plain/core/linux-lts/config?id=${I686_CONFIG_HASH}
- -> linux-${I686_CONFIG_VER}.i686.config
- )"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- !sys-kernel/vanilla-kernel-bin:${SLOT}"
-
-pkg_pretend() {
- mount-boot_pkg_pretend
-
- ewarn "This is an experimental package. The built kernel and/or initramfs"
- ewarn "may not work at all or fail with your bootloader configuration. Please"
- ewarn "make sure to keep a backup kernel available before testing it."
-}
-
-src_prepare() {
- default
-
- # prepare the default config
- case ${ARCH} in
- amd64)
- cp "${DISTDIR}"/linux-${AMD64_CONFIG_VER}.amd64.config .config || die
- ;;
- x86)
- cp "${DISTDIR}"/linux-${I686_CONFIG_VER}.i686.config .config || die
- ;;
- *)
- die "Unsupported arch ${ARCH}"
- ;;
- esac
-
- local config_tweaks=(
- # shove arch under the carpet!
- -e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
- # we do support x32
- -e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
- # disable signatures
- -e '/CONFIG_MODULE_SIG/d'
- -e '/CONFIG_SECURITY_LOCKDOWN/d'
- # disable compression to allow stripping
- -e '/CONFIG_MODULE_COMPRESS/d'
- # disable gcc plugins to unbreak distcc
- -e '/CONFIG_GCC_PLUGIN_STRUCTLEAK/d'
- )
- sed -i "${config_tweaks[@]}" .config || die
-}