summaryrefslogtreecommitdiff
path: root/sys-kernel/scx/scx-1.0.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/scx/scx-1.0.10.ebuild')
-rw-r--r--sys-kernel/scx/scx-1.0.10.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-kernel/scx/scx-1.0.10.ebuild b/sys-kernel/scx/scx-1.0.10.ebuild
index 8e371a730f10..fb14fc6c3c40 100644
--- a/sys-kernel/scx/scx-1.0.10.ebuild
+++ b/sys-kernel/scx/scx-1.0.10.ebuild
@@ -10,7 +10,7 @@ CRATES="
RUST_MIN_VER="1.74.1"
-inherit llvm-r1 linux-info cargo rust-toolchain meson
+inherit llvm-r1 linux-info cargo rust-toolchain toolchain-funcs meson
DESCRIPTION="sched_ext schedulers and tools"
HOMEPAGE="https://github.com/sched-ext/scx"
@@ -70,9 +70,11 @@ pkg_setup() {
src_prepare() {
default
- # Inject the rust_abi value into install_rust_user_scheds
- sed -i "s;\${MESON_BUILD_ROOT};\${MESON_BUILD_ROOT}/$(rust_abi);" \
- meson-scripts/install_rust_user_scheds || die
+ if tc-is-cross-compiler; then
+ # Inject the rust_abi value into install_rust_user_scheds
+ sed -i "s;\${MESON_BUILD_ROOT};\${MESON_BUILD_ROOT}/$(rust_abi);" \
+ meson-scripts/install_rust_user_scheds || die
+ fi
# bug #944832
sed -i 's;^#!/usr/bin/;#!/sbin/;' \