summaryrefslogtreecommitdiff
path: root/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201-r1.ebuild')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201-r1.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201-r1.ebuild
new file mode 100644
index 000000000000..9ce67ae0b2a1
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+
+inherit kernel-2 eapi7-ver
+detect_version
+
+MY_P=$(ver_cut 4-)
+MY_P="raspberrypi-kernel_1.${MY_P/p/}-1"
+
+DESCRIPTION="Raspberry Pi kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+SRC_URI="https://github.com/raspberrypi/linux/archive/${MY_P}.tar.gz"
+
+KEYWORDS="~arm ~arm64"
+
+src_unpack() {
+ default
+
+ # We want to rename the unpacked directory to a nice normalised string
+ # bug #762766
+ mv "${WORKDIR}"/linux-${MY_P} "${WORKDIR}"/linux-${KV_FULL} || die
+}