summaryrefslogtreecommitdiff
path: root/sys-kernel/raspberrypi-image/raspberrypi-image-4.19.57_p20190709.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/raspberrypi-image/raspberrypi-image-4.19.57_p20190709.ebuild')
-rw-r--r--sys-kernel/raspberrypi-image/raspberrypi-image-4.19.57_p20190709.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-image/raspberrypi-image-4.19.57_p20190709.ebuild b/sys-kernel/raspberrypi-image/raspberrypi-image-4.19.57_p20190709.ebuild
new file mode 100644
index 000000000000..ecd30c095746
--- /dev/null
+++ b/sys-kernel/raspberrypi-image/raspberrypi-image-4.19.57_p20190709.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mount-boot
+
+DESCRIPTION="Raspberry Pi (all versions) kernel and modules"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+RESTRICT="binchecks strip"
+
+RDEPEND="sys-boot/raspberrypi-firmware"
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
+ EGIT_CLONE_TYPE="shallow"
+else
+ [[ "$(ver_cut 4)" == 'p' ]] || die "Unsupported version format, tweak the ebuild."
+ MY_PV="1.$(ver_cut 5)"
+ SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> raspberrypi-firmware-${MY_PV}.tar.gz"
+ S="${WORKDIR}/firmware-${MY_PV}"
+ KEYWORDS="-* ~arm"
+fi
+
+src_install() {
+ insinto /lib/modules
+ doins -r modules/*
+ insinto /boot
+ doins boot/*.img
+}