summaryrefslogtreecommitdiff
path: root/sys-kernel/modprobed-db/modprobed-db-2.46.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/modprobed-db/modprobed-db-2.46.ebuild')
-rw-r--r--sys-kernel/modprobed-db/modprobed-db-2.46.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-kernel/modprobed-db/modprobed-db-2.46.ebuild b/sys-kernel/modprobed-db/modprobed-db-2.46.ebuild
new file mode 100644
index 000000000000..d23c0c8d827e
--- /dev/null
+++ b/sys-kernel/modprobed-db/modprobed-db-2.46.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Keeps track of EVERY kernel module ever used - useful for make localmodconfig"
+HOMEPAGE="https://github.com/graysky2/modprobed-db"
+SRC_URI="https://github.com/graysky2/modprobed-db/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_prepare() {
+ # Automatically compresses manpages, which is a PMS functionality
+ # (and every other distro has the same policy!).
+ sed -i '/gzip -9/d' Makefile || die
+ default
+}
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr" INITDIR_SYSTEMD="$(systemd_get_userunitdir)"
+}