summaryrefslogtreecommitdiff
path: root/sys-kernel/installkernel-systemd-boot
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/installkernel-systemd-boot')
-rw-r--r--sys-kernel/installkernel-systemd-boot/Manifest5
-rw-r--r--sys-kernel/installkernel-systemd-boot/files/00-00machineid-directory.install28
-rw-r--r--sys-kernel/installkernel-systemd-boot/files/installkernel-systemd-boot-2-r2-00-00machineid-directory.install32
-rw-r--r--sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-2-r1.ebuild29
-rw-r--r--sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-2-r3.ebuild35
-rw-r--r--sys-kernel/installkernel-systemd-boot/metadata.xml8
6 files changed, 0 insertions, 137 deletions
diff --git a/sys-kernel/installkernel-systemd-boot/Manifest b/sys-kernel/installkernel-systemd-boot/Manifest
deleted file mode 100644
index 9bc67bebb575..000000000000
--- a/sys-kernel/installkernel-systemd-boot/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX 00-00machineid-directory.install 694 BLAKE2B d4347645fb0a6401fc2b3ed43dac6c925591c289484a1946be137045066e5064d6df0aa9d547c1b720683434636b16a6a182c7b1ba18faf9733ce984e4a5b4b0 SHA512 f8af2f19a605b59f54662dfa909254de4fe2f4f5334d7bce7c6c5babb8e78382b6497a4a28d6d34b5c27af3f5b5b55772d0a1b8ade98cb63eb5d9266e7b9067e
-AUX installkernel-systemd-boot-2-r2-00-00machineid-directory.install 737 BLAKE2B cc4c2d2cf91de01f42242ce995c79afbb23deb942265ad0a57490260a22b1fc1aac5d85221f03fe93f3d337fbe36e69e3c57b13ec7d90129aa4d4c6949167cad SHA512 427363db8acded018621b23d97b64cbe897ffc08b75dc3f1aa669b24907f6bce7cc8978614f9327dbc125ae0184c84abf8087a08fcbf19651a0c6f9bbb4cd6e9
-EBUILD installkernel-systemd-boot-2-r1.ebuild 811 BLAKE2B 650427828e062194127b4ae6b9a5a5748fdd1965673580bffc8e63429a8d6a694177bd08851def3179059e33c85f076fd188cf1b5c514304e4e7b793a028a5c2 SHA512 532b7751a0d246c205140fb204ef38b27d7fba63472d3dab3760fab7bdc2d965998d7c0d5243affd70a51cd2a5de1328a212cbb3c52bf7db64df2092ed30f9b6
-EBUILD installkernel-systemd-boot-2-r3.ebuild 867 BLAKE2B e06084bff9a4f88d0cefd2c5f524d6e24b5420611d1805c6d7c763fc223574e140d1a509e23327a6be9f84af8f69891e47c4151100bbe32e81865eebf14614c3 SHA512 4688044f7c922b9d9c648471d08fabed9f0e3e5d4f756b4f17f3608964a7327c722925956d2b623b854ef46e614183edf77ab4f914bb734c6f357d8b3713e9e8
-MISC metadata.xml 267 BLAKE2B 4449a3159ae97fc4f2152d9305dc77bf8df18a3dc3ae5881b9e56fc0a30da17d7dabf24901b421389b0cea4b7f0037f46e193d8a74a79431c1ccbd3db1fde9ea SHA512 54190f2ef340d1e355087b7a9af6f651be3704bbf23600f024eabb1bdffd36fd92c1f3f37b409dbde82f52b5287e08a427537ca1028bc326d19470f755cefd43
diff --git a/sys-kernel/installkernel-systemd-boot/files/00-00machineid-directory.install b/sys-kernel/installkernel-systemd-boot/files/00-00machineid-directory.install
deleted file mode 100644
index 70b966fbf4b3..000000000000
--- a/sys-kernel/installkernel-systemd-boot/files/00-00machineid-directory.install
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/usr/bin/env bash
-
-# this file is installed by sys-kernel/installkernel-systemd-boot
-
-COMMAND="${1}"
-ENTRY_DIR_ABS="${3}"
-
-# this is exported by kernel-install
-if ! [[ $KERNEL_INSTALL_MACHINE_ID ]]; then
- exit 0
-fi
-
-if [[ $COMMAND != add ]]; then
- exit 0
-fi
-
-# If the machine-id dir does not exist (e.g. $ESP/<machine-id>)
-# create it. It receives values directly from kernel-install.
-# This is the only function of this plugin.
-MACHINE_ID_DIR="${ENTRY_DIR_ABS%/*}"
-if ! [[ -d "${MACHINE_ID_DIR}" ]]; then
- if [[ "${KERNEL_INSTALL_VERBOSE}" -gt 0 ]]; then
- echo "+mkdir -v -p ${MACHINE_ID_DIR}"
- mkdir -v -p "${MACHINE_ID_DIR}"
- else
- mkdir -p "${MACHINE_ID_DIR}"
- fi
-fi
diff --git a/sys-kernel/installkernel-systemd-boot/files/installkernel-systemd-boot-2-r2-00-00machineid-directory.install b/sys-kernel/installkernel-systemd-boot/files/installkernel-systemd-boot-2-r2-00-00machineid-directory.install
deleted file mode 100644
index 5fa3bbeffc04..000000000000
--- a/sys-kernel/installkernel-systemd-boot/files/installkernel-systemd-boot-2-r2-00-00machineid-directory.install
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/usr/bin/env sh
-
-# this file is installed by sys-kernel/installkernel-systemd-boot
-
-COMMAND="${1}"
-ENTRY_DIR_ABS="${3}"
-
-# this is exported by kernel-install
-if [ -z "${KERNEL_INSTALL_MACHINE_ID}" ]; then
- exit 0
-fi
-
-if [ "${KERNEL_INSTALL_LAYOUT}" = "uki" ]; then
- exit 0
-fi
-
-if [ "${COMMAND}" != "add" ]; then
- exit 0
-fi
-
-# If the machine-id dir does not exist (e.g. $ESP/<machine-id>)
-# create it. It receives values directly from kernel-install.
-# This is the only function of this plugin.
-MACHINE_ID_DIR="${ENTRY_DIR_ABS%/*}"
-if ! [ -d "${MACHINE_ID_DIR}" ]; then
- if [ "${KERNEL_INSTALL_VERBOSE}" = "1" ]; then
- echo "+mkdir -v -p ${MACHINE_ID_DIR}"
- mkdir -v -p "${MACHINE_ID_DIR}"
- else
- mkdir -p "${MACHINE_ID_DIR}"
- fi
-fi
diff --git a/sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-2-r1.ebuild b/sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-2-r1.ebuild
deleted file mode 100644
index b4b0308233e7..000000000000
--- a/sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-2-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Wrap kernel-install from systemd-boot as installkernel"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="amd64 arm64 ppc64 x86"
-
-RDEPEND="|| ( sys-apps/systemd sys-apps/systemd-utils[boot] )
- !<sys-apps/debianutils-4.9-r1[installkernel(+)]
- !sys-kernel/installkernel-gentoo"
-
-src_install() {
- # we could technically use a symlink here but it would require
- # us to know the correct path, and that implies /usr merge problems
- into /
- newsbin - installkernel <<-EOF
- #!/usr/bin/env sh
- exec kernel-install add "\${1}" "\${2}"
- EOF
-
- exeinto /usr/lib/kernel/install.d/
- doexe "${FILESDIR}/00-00machineid-directory.install"
-}
diff --git a/sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-2-r3.ebuild b/sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-2-r3.ebuild
deleted file mode 100644
index 6ecb8c8f7702..000000000000
--- a/sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-2-r3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Wrap kernel-install from systemd-boot as installkernel"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-S="${WORKDIR}"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~loong ppc64 x86"
-
-RDEPEND="
- !sys-kernel/installkernel-gentoo
- || (
- sys-apps/systemd[gnuefi(-)]
- sys-apps/systemd[boot(-)]
- sys-apps/systemd-utils[boot]
- )
-"
-
-src_install() {
- # we could technically use a symlink here but it would require
- # us to know the correct path, and that implies /usr merge problems
- into /
- newsbin - installkernel <<-EOF
- #!/usr/bin/env sh
- exec kernel-install add "\${1}" "\${2}"
- EOF
-
- exeinto /usr/lib/kernel/install.d/
- newexe "${FILESDIR}/${PN}-2-r2-00-00machineid-directory.install" \
- 00-00machineid-directory.install
-}
diff --git a/sys-kernel/installkernel-systemd-boot/metadata.xml b/sys-kernel/installkernel-systemd-boot/metadata.xml
deleted file mode 100644
index fae0ca9e8b97..000000000000
--- a/sys-kernel/installkernel-systemd-boot/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>dist-kernel@gentoo.org</email>
- <name>Distribution Kernel Project</name>
- </maintainer>
-</pkgmetadata>