summaryrefslogtreecommitdiff
path: root/sys-kernel/dracut/dracut-059-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/dracut/dracut-059-r2.ebuild')
-rw-r--r--sys-kernel/dracut/dracut-059-r2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-kernel/dracut/dracut-059-r2.ebuild b/sys-kernel/dracut/dracut-059-r2.ebuild
index 5aa6cfb4a241..1fd75386ff36 100644
--- a/sys-kernel/dracut/dracut-059-r2.ebuild
+++ b/sys-kernel/dracut/dracut-059-r2.ebuild
@@ -156,10 +156,13 @@ pkg_postinst() {
optfeature \
"Allows use of dash instead of default bash (on your own risk)" \
app-shells/dash
+ optfeature \
+ "Allows use of busybox instead of default bash (on your own risk)" \
+ sys-apps/busybox
optfeature "Support iSCSI" sys-block/open-iscsi
optfeature "Support Logical Volume Manager" sys-fs/lvm2[lvm]
optfeature "Support MD devices, also known as software RAID devices" \
- sys-fs/mdadm
+ sys-fs/mdadm sys-fs/dmraid
optfeature "Support Device Mapper multipathing" sys-fs/multipath-tools
optfeature "Plymouth boot splash" '>=sys-boot/plymouth-0.8.5-r5'
optfeature "Support network block devices" sys-block/nbd
@@ -168,6 +171,11 @@ pkg_postinst() {
"Install ssh and scp along with config files and specified keys" \
virtual/openssh
optfeature "Enable logging with rsyslog" app-admin/rsyslog
+ optfeature "Support Squashfs" sys-fs/squashfs-tools
+ optfeature "Support TPM 2.0 TSS" app-crypt/tpm2-tools
+ optfeature "Support Bluetooth (experimental)" net-wireless/bluez
+ optfeature "Support BIOS-given device names" sys-apps/biosdevname
+ optfeature "Support network NVMe" sys-apps/nvme-cli
optfeature \
"Enable rngd service to help generating entropy early during boot" \
sys-apps/rng-tools