summaryrefslogtreecommitdiff
path: root/sys-fs/zfs/zfs-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/zfs/zfs-9999.ebuild')
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index ccf810c825f2..1c02c0298585 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -115,6 +115,7 @@ src_prepare() {
src_configure() {
use custom-cflags || strip-flags
+ python_setup
local myconf=(
--bindir="${EPREFIX}/bin"
@@ -128,6 +129,7 @@ src_configure() {
--with-linux="${KV_DIR}"
--with-linux-obj="${KV_OUT_DIR}"
--with-udevdir="$(get_udevdir)"
+ --with-python="${EPYTHON}"
--with-systemdunitdir="$(systemd_get_systemunitdir)"
--with-systemdpresetdir="${EPREFIX}/lib/systemd/system-preset"
$(use_enable debug)
@@ -171,7 +173,6 @@ src_install() {
fi
# enforce best available python implementation
- python_setup
python_fix_shebang "${ED}/bin"
}