summaryrefslogtreecommitdiff
path: root/sys-fs/zfs/zfs-0.8.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/zfs/zfs-0.8.2-r2.ebuild')
-rw-r--r--sys-fs/zfs/zfs-0.8.2-r2.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-fs/zfs/zfs-0.8.2-r2.ebuild b/sys-fs/zfs/zfs-0.8.2-r2.ebuild
index fea065189c3f..341a978b2793 100644
--- a/sys-fs/zfs/zfs-0.8.2-r2.ebuild
+++ b/sys-fs/zfs/zfs-0.8.2-r2.ebuild
@@ -124,6 +124,7 @@ src_prepare() {
src_configure() {
use custom-cflags || strip-flags
+ python_setup
local myconf=(
--bindir="${EPREFIX}/bin"
@@ -137,6 +138,7 @@ src_configure() {
--with-linux="${KV_DIR}"
--with-linux-obj="${KV_OUT_DIR}"
--with-udevdir="$(get_udevdir)"
+ --with-python="${EPYTHON}"
--with-systemdunitdir="$(systemd_get_systemunitdir)"
--with-systemdpresetdir="${EPREFIX}/lib/systemd/system-preset"
$(use_enable debug)
@@ -180,7 +182,6 @@ src_install() {
fi
# enforce best available python implementation
- python_setup
python_fix_shebang "${ED}/bin"
}