summaryrefslogtreecommitdiff
path: root/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/zfs-kmod/zfs-kmod-9999.ebuild')
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-9999.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
index e8dbe7749786..87090d4d5e0f 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic linux-info linux-mod toolchain-funcs
+inherit flag-o-matic linux-mod toolchain-funcs
DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
HOMEPAGE="https://zfsonlinux.org/"
@@ -38,8 +38,6 @@ RESTRICT="debug? ( strip ) test"
DOCS=( AUTHORS COPYRIGHT META README.md )
pkg_setup() {
- linux-info_pkg_setup
-
CONFIG_CHECK="
!DEBUG_LOCK_ALLOC
EFI_PARTITION
@@ -80,7 +78,7 @@ pkg_setup() {
"Linux ${kv_major_max}.${kv_minor_max} is the latest supported version"
fi
- check_extra_config
+ linux-mod_pkg_setup
}
src_prepare() {
@@ -92,9 +90,6 @@ src_prepare() {
# Set module revision number
sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" META || die "Could not set Gentoo release"
fi
-
- # Remove GPLv2-licensed ZPIOS unless we are debugging
- use debug || sed -e 's/^subdir-m += zpios$//' -i module/Makefile.in
}
src_configure() {