summaryrefslogtreecommitdiff
path: root/sys-fs/xwmfs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/xwmfs')
-rw-r--r--sys-fs/xwmfs/Manifest3
-rw-r--r--sys-fs/xwmfs/metadata.xml34
-rw-r--r--sys-fs/xwmfs/xwmfs-0.81.ebuild20
3 files changed, 57 insertions, 0 deletions
diff --git a/sys-fs/xwmfs/Manifest b/sys-fs/xwmfs/Manifest
new file mode 100644
index 000000000000..468d9f0febcc
--- /dev/null
+++ b/sys-fs/xwmfs/Manifest
@@ -0,0 +1,3 @@
+DIST xwmfs-0.81.tar.gz 192750 SHA256 490f9186681dfce8b6576f81130cfce6f51fd5d5a70a8554637946c5bf831c6a SHA512 7b11e4f38654144467b128fcdd84082f3d5f16817d6b40285a0726165bb16c34ea076981d5866c952ce74e9a21b6b2dbcf53ed96631fd13d7b263a55cb6a577a WHIRLPOOL 0ee5a4fff41ba2330dc777a89e686e3e8f954f61c53c265a7208856cbec4cc01596bedb23819e8e222f31a31a1ac34bf3cf0c2b934c117718dfb8894a8e86b5c
+EBUILD xwmfs-0.81.ebuild 474 SHA256 4496e9790f09044897cded846663ae322569ab785d8fb0b33dba92cbbcab2bc3 SHA512 d0407b47a93f0fb89db0e444b1886a842a3c7e864e5af9c3c48ca6ab7216ec6cf7c9172e7b75ce8225dcc10c8fc7eb8889e68fedce03fb2d9226bac8ba76ea09 WHIRLPOOL 806ab4bb18e934dd6d73f29a2d87329715156b0ab0275b9e5b026acce355ae289a8dfde73570272d0e2dfa340cf4bce37c327c87270e2bd185c56706fb4123e6
+MISC metadata.xml 1393 SHA256 d2ea9ff195baecaebc3d80a8684a98f8e7a59b4d2691c9e4e420e1f33b6627f3 SHA512 143ed4a1f942d55be296a6b909d56d853e7b27a9710f9d4248bd7102a47a49b804f3687abc2d508209889b12cbfcfdd07f8bdba94883858f1605e59964675951 WHIRLPOOL f16df5ceda54266d95a4942e7ab530b8051bb950fdd09749b71ef9163ebedebae98be5cd2f48caea85a4ae3ce7ac2fbee42eb649e03196e0d05cec04c3f3a4cb
diff --git a/sys-fs/xwmfs/metadata.xml b/sys-fs/xwmfs/metadata.xml
new file mode 100644
index 000000000000..8b58b472e953
--- /dev/null
+++ b/sys-fs/xwmfs/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>matthias.gerstner@nefkom.net</email>
+ <name>Matthias Gerstner</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is xwmfs (X window manager file system), a userspace file system based on
+ fuse that allows interaction with an EWMH compliant X11 window manager
+ via files.
+
+ Some of its features are:
+
+ - newly appearing and disappearing windows in the X server are recognized and
+ the file system is updated in an event based manner
+ - new values for properties of window manager and windows will be reflected in
+ the file system in an event based manner
+ - properties of windows and window manager can be changed via writing to files
+ in the file system
+ - some X operations are accessible via control files in the file system
+
+ The file system can be used for easily implementing scripts that operate on
+ the window manager and windows (for example identifying specific windows,
+ rename a window, move it around and so on).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gestner-hub/xwmfs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/xwmfs/xwmfs-0.81.ebuild b/sys-fs/xwmfs/xwmfs-0.81.ebuild
new file mode 100644
index 000000000000..aa134c2864b1
--- /dev/null
+++ b/sys-fs/xwmfs/xwmfs-0.81.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="FUSE-based X11 Window-Manager file system"
+HOMEPAGE="https://github.com/gerstner-hub/xwmfs"
+SRC_URI="https://github.com/gerstner-hub/${PN}/releases/download/v${PV}/${P}-dist.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~arm"
+SLOT="0"
+
+RDEPEND="
+ sys-fs/fuse:=
+ >=x11-libs/libX11-1.6.5"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"