summaryrefslogtreecommitdiff
path: root/sys-fs/udev/udev-249-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/udev/udev-249-r2.ebuild')
-rw-r--r--sys-fs/udev/udev-249-r2.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/sys-fs/udev/udev-249-r2.ebuild b/sys-fs/udev/udev-249-r2.ebuild
index a77771e66f71..08a32a5d3c7b 100644
--- a/sys-fs/udev/udev-249-r2.ebuild
+++ b/sys-fs/udev/udev-249-r2.ebuild
@@ -198,32 +198,30 @@ multilib_src_compile() {
eninja "${targets[@]}"
}
-multilib_src_test() {
+src_test() {
# The testsuite is *very* finicky. Don't try running it in
# containers or anything but a full VM or on bare metal.
# udev calls 'mknod' a number of times, and this interacts
# badly with kernel namespaces.
- if [[ ${EUID} -ne 0 ]]; then
- ewarn "udev tests need to run under uid 0"
- ewarn "Skipping tests"
- elif has sandbox ${FEATURES}; then
- ewarn "\'FEATURES=sandbox\' detected"
+ if [[ ! -w /dev ]]; then
ewarn "udev tests needs full access to /dev"
ewarn "Skipping tests"
else
- einfo Running tests
+ meson-multilib_src_test
+ fi
+}
- # two binaries required by udev-test.pl
- eninja systemd-detect-virt test-udev
- local -x PATH="${PWD}:${PATH}"
+multilib_src_test() {
+ # two binaries required by udev-test.pl
+ eninja systemd-detect-virt test-udev
+ local -x PATH="${PWD}:${PATH}"
- # prepare ${BUILD_DIR}/test/sys, required by udev-test.pl
- "${EPYTHON}" "${S}"/test/sys-script.py test || die
+ # prepare ${BUILD_DIR}/test/sys, required by udev-test.pl
+ "${EPYTHON}" "${S}"/test/sys-script.py test || die
- # the perl script contains all the udev tests
- "${S}"/test/udev-test.pl || die
- fi
+ # the perl script contains all the udev tests
+ "${S}"/test/udev-test.pl || die
}
multilib_src_install() {