summaryrefslogtreecommitdiff
path: root/sys-fs/simple-mtpfs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/simple-mtpfs')
-rw-r--r--sys-fs/simple-mtpfs/Manifest1
-rw-r--r--sys-fs/simple-mtpfs/simple-mtpfs-0.4.0-r1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-fs/simple-mtpfs/Manifest b/sys-fs/simple-mtpfs/Manifest
index f2015e130840..b86149ba5ec3 100644
--- a/sys-fs/simple-mtpfs/Manifest
+++ b/sys-fs/simple-mtpfs/Manifest
@@ -1,3 +1,4 @@
DIST simple-mtpfs-0.4.0.tar.gz 36234 BLAKE2B ec5739625286b63dc6285fb83a4c71f5ed9bb8ed757eab111e543e15efbc45a5fc3a2609382f01cf18d4c6160258800963c349b6d64b2648257cde99f9359432 SHA512 6f213f9df792f33cd3842357aecf444cdc8030c89e4abc19b56a2c60f58213b5545b3d7857b0d46cdd237d0c24d5d6eb3cbe59ba9fc3c32f91396c5724ac86d7
+EBUILD simple-mtpfs-0.4.0-r1.ebuild 616 BLAKE2B a6aa11f22724e0e97c38c990f54aef2426dd8b00662c6dbd2c73f5e61a8a4e8fa220cb321c58f35118a5c30cd18ad52f96e7033d0871d29388ea2800e0e80f93 SHA512 4da9cebe68f168573f6babaf2fde6d18cd1e09f90bdb3051251586ec0c41d5350d533dc6d2de31450778bed001d7613ce943fac332ef1e2abf379576ba13663e
EBUILD simple-mtpfs-0.4.0.ebuild 613 BLAKE2B af4bbc6c6a3297bab7a5885bbb6a58f1de6e84afff9110d27d7c419140ae71e6e984fa314d4f6971a0fcab98fd5bc4f75980a67a81831a9f8efe2036d2cdfe65 SHA512 750ec138321bb2de7400e710334c63d074e596ee86365dd71c2590941766ef013c0e0dab0f27afd9905bff189eeddf0ba0347ea363ceeb42db169eecf1288fbe
MISC metadata.xml 882 BLAKE2B 0e3e9fe17ed59c0aa1158e3cead024273d280a56a05b00268f2f981bc9cf96181b3296fe8b4ba85cf7f022c3d20773bc2f7d05695b06e1708eeba153da65c672 SHA512 9460fef344fdae709e10fb2d2164656d4ab9244d5881c75e23ff05f00cfc662c096679ddda841e2a0cf800fb6c36eb6eabe0c168a72a5db3e3f9e1166893b750
diff --git a/sys-fs/simple-mtpfs/simple-mtpfs-0.4.0-r1.ebuild b/sys-fs/simple-mtpfs/simple-mtpfs-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..d915d61c898d
--- /dev/null
+++ b/sys-fs/simple-mtpfs/simple-mtpfs-0.4.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Simple MTP fuse filesystem driver"
+HOMEPAGE="https://github.com/phatina/simple-mtpfs"
+SRC_URI="https://github.com/phatina/simple-mtpfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libmtp
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-build/autoconf-archive
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # The tarball doesn't contain ./configure, only configure.ac and
+ # autogen.sh.
+ eautoreconf
+}