summaryrefslogtreecommitdiff
path: root/sys-fs/multipath-tools/files/multipath-tools-0.9.4-remove-Werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/multipath-tools/files/multipath-tools-0.9.4-remove-Werror.patch')
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.9.4-remove-Werror.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.9.4-remove-Werror.patch b/sys-fs/multipath-tools/files/multipath-tools-0.9.4-remove-Werror.patch
new file mode 100644
index 000000000000..58c8ae291ce8
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.9.4-remove-Werror.patch
@@ -0,0 +1,45 @@
+--- a/Makefile.inc
++++ b/Makefile.inc
+@@ -79,7 +79,7 @@
+ SYSTEMD_LIBDEPS := $(if $(SYSTEMD),$(if $(shell test $(SYSTEMD) -gt 209 && echo 1),-lsystemd,-lsystemd-daemon))
+
+ OPTFLAGS := -O2 -g $(STACKPROT) --param=ssp-buffer-size=4
+-WARNFLAGS := -Werror -Wall -Wextra -Wformat=2 $(WFORMATOVERFLOW) -Werror=implicit-int \
++WARNFLAGS := -Wall -Wextra -Wformat=2 $(WFORMATOVERFLOW) -Werror=implicit-int \
+ -Werror=implicit-function-declaration -Werror=format-security \
+ $(WNOCLOBBERED) -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS) $(W_URCU_TYPE_LIMITS)
+ CPPFLAGS := $(FORTIFY_OPT) $(CPPFLAGS) \
+--- a/create-config.mk
++++ b/create-config.mk
+@@ -64,7 +64,7 @@
+ # gcc 4.8 compiles blacklist.c only with -Wno-missing-field-initializers
+ TEST_MISSING_INITIALIZERS = $(shell \
+ echo 'struct A {int a, b;}; struct B {struct A a; int b;} b = {.a.a=1};' | \
+- $(CC) -c -Werror -Wmissing-field-initializers -o /dev/null -xc - >/dev/null 2>&1 \
++ $(CC) -c -Wmissing-field-initializers -o /dev/null -xc - >/dev/null 2>&1 \
+ || echo -Wno-missing-field-initializers)
+
+ # gcc 4.8.4 and certain versions of liburcu fail to compile this with -Werror=type-limits
+@@ -123,7 +123,7 @@
+ # Evaluates to "option" if yes, and "fallback" otherwise.
+ TEST_CC_OPTION = $(shell \
+ if echo 'int main(void){return 0;}' | \
+- $(CC) -o /dev/null -c -Werror "$(1)" -xc - >/dev/null 2>&1; \
++ $(CC) -o /dev/null -c "$(1)" -xc - >/dev/null 2>&1; \
+ then \
+ echo "$(1)"; \
+ else \
+@@ -135,11 +135,11 @@
+ # but it doesn't seem to make a difference wrt the compilation result.
+ FORTIFY_OPT := $(shell \
+ if /bin/echo -e '$(__HASH__)include <string.h>\nint main(void) { return 0; }' | \
+- $(CC) -o /dev/null $(OPTFLAGS) -c -Werror -D_FORTIFY_SOURCE=3 -xc - 2>/dev/null; \
++ $(CC) -o /dev/null $(OPTFLAGS) -c -D_FORTIFY_SOURCE=3 -xc - 2>/dev/null; \
+ then \
+ echo "-D_FORTIFY_SOURCE=3"; \
+ elif /bin/echo -e '$(__HASH__)include <string.h>\nint main(void) { return 0; }' | \
+- $(CC) -o /dev/null $(OPTFLAGS) -c -Werror -D_FORTIFY_SOURCE=2 -xc - 2>/dev/null; \
++ $(CC) -o /dev/null $(OPTFLAGS) -c -D_FORTIFY_SOURCE=2 -xc - 2>/dev/null; \
+ then \
+ echo "-D_FORTIFY_SOURCE=2"; \
+ fi)