summaryrefslogtreecommitdiff
path: root/sys-fs/mtools/mtools-4.0.35.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/mtools/mtools-4.0.35.ebuild')
-rw-r--r--sys-fs/mtools/mtools-4.0.35.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-fs/mtools/mtools-4.0.35.ebuild b/sys-fs/mtools/mtools-4.0.35.ebuild
new file mode 100644
index 000000000000..3ebdd3b6df91
--- /dev/null
+++ b/sys-fs/mtools/mtools-4.0.35.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="utilities to access MS-DOS disks from Unix without mounting them"
+HOMEPAGE="https://www.gnu.org/software/mtools/ https://savannah.gnu.org/projects/mtools"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x64-solaris"
+IUSE="X elibc_glibc"
+
+RDEPEND="
+ !elibc_glibc? ( virtual/libiconv )
+ X? (
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXt
+ )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ use !elibc_glibc && use !elibc_musl && append-libs "-liconv" #447688
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/mtools
+ $(use_with X x)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local -a DOCS=( README* Release.notes )
+ default
+
+ insinto /etc/mtools
+ doins mtools.conf
+
+ # default is fine
+ sed -i -e '/^SAMPLE FILE$/s:^:#:' "${ED}"/etc/mtools/mtools.conf || die
+}