summaryrefslogtreecommitdiff
path: root/sys-fs/lvm2/lvm2-2.02.145-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/lvm2/lvm2-2.02.145-r2.ebuild')
-rw-r--r--sys-fs/lvm2/lvm2-2.02.145-r2.ebuild44
1 files changed, 4 insertions, 40 deletions
diff --git a/sys-fs/lvm2/lvm2-2.02.145-r2.ebuild b/sys-fs/lvm2/lvm2-2.02.145-r2.ebuild
index ca67d8edf577..2890ca59239e 100644
--- a/sys-fs/lvm2/lvm2-2.02.145-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.145-r2.ebuild
@@ -12,19 +12,11 @@ SRC_URI="ftp://sourceware.org/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE="readline static static-libs systemd clvm cman corosync lvm1 lvm2create_initrd openais selinux +udev +thin device-mapper-only"
-REQUIRED_USE="device-mapper-only? ( !clvm !cman !corosync !lvm1 !lvm2create_initrd !openais !thin )
- systemd? ( udev )
- clvm? ( !systemd )"
+IUSE="readline static static-libs systemd lvm1 lvm2create_initrd selinux +udev +thin device-mapper-only"
+REQUIRED_USE="device-mapper-only? ( !lvm1 !lvm2create_initrd !thin )
+ systemd? ( udev )"
DEPEND_COMMON="
- clvm? (
- cman? ( =sys-cluster/cman-3* )
- corosync? ( sys-cluster/corosync )
- openais? ( sys-cluster/openais )
- =sys-cluster/libdlm-3*
- )
-
readline? ( sys-libs/readline:0= )
systemd? ( >=sys-apps/systemd-205:0= )
udev? ( >=virtual/libudev-208:=[static-libs?] )"
@@ -35,7 +27,6 @@ RDEPEND="${DEPEND_COMMON}
>=sys-apps/baselayout-2.2
!<sys-apps/openrc-0.11
!<sys-fs/cryptsetup-1.1.2
- !!sys-fs/clvm
!!sys-fs/lvm-user
>=sys-apps/util-linux-2.16
lvm2create_initrd? ( sys-apps/makedev )
@@ -167,29 +158,7 @@ src_configure() {
# disable O_DIRECT support on hppa, breaks pv detection (#99532)
use hppa && myconf+=( --disable-o_direct )
- if use clvm; then
- myconf+=( --with-cluster=${buildmode} )
- # 4-state! Make sure we get it right, per bug 210879
- # Valid options are: none, cman, gulm, all
- #
- # 2009/02:
- # gulm is removed now, now dual-state:
- # cman, none
- # all still exists, but is not needed
- #
- # 2009/07:
- # TODO: add corosync and re-enable ALL
- local clvmd=""
- use cman && clvmd="cman"
- #clvmd="${clvmd/cmangulm/all}"
- use corosync && clvmd="${clvmd:+$clvmd,}corosync"
- use openais && clvmd="${clvmd:+$clvmd,}openais"
- [ -z "${clvmd}" ] && clvmd="none"
- myconf+=( --with-clvmd=${clvmd} )
- myconf+=( --with-pool=${buildmode} )
- else
- myconf+=( --with-clvmd=none --with-cluster=none )
- fi
+ myconf+=( --with-clvmd=none --with-cluster=none )
econf \
$(use_enable readline) \
@@ -249,11 +218,6 @@ src_install() {
newinitd "${FILESDIR}"/lvmetad.initd-2.02.116-r3 lvmetad
fi
- if use clvm; then
- newinitd "${FILESDIR}"/clvmd.rc-2.02.39 clvmd
- newconfd "${FILESDIR}"/clvmd.confd-2.02.39 clvmd
- fi
-
if use static-libs; then
dolib.a libdm/ioctl/libdevmapper.a
if use !device-mapper-only ; then