summaryrefslogtreecommitdiff
path: root/sys-fs/lde/lde-2.6.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/lde/lde-2.6.1-r2.ebuild')
-rw-r--r--sys-fs/lde/lde-2.6.1-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-fs/lde/lde-2.6.1-r2.ebuild b/sys-fs/lde/lde-2.6.1-r2.ebuild
new file mode 100644
index 000000000000..c0b1f4584101
--- /dev/null
+++ b/sys-fs/lde/lde-2.6.1-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="ext2fs and minix disk editor for linux"
+HOMEPAGE="http://lde.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ virtual/yacc
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-shadowing.patch"
+ "${FILESDIR}/${P}-fno-common.patch"
+ "${FILESDIR}/${P}-tinfo.patch"
+ "${FILESDIR}/${P}-respect-ar.patch"
+)
+
+DOCS=( WARNING README TODO COPYING )
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ # Remove prebuilt lde binary (so that failures to compile are fatal!)
+ # bug #776862
+ rm lde || die
+
+ cd macros || die
+ # bug #775968 again
+ touch ar-lib install-sh || die
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ dosbin "${PN}"
+ newman "doc/${PN}.man" "${PN}.8"
+ einstalldocs
+}