summaryrefslogtreecommitdiff
path: root/sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.30.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.30.ebuild')
-rw-r--r--sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.30.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.30.ebuild b/sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.30.ebuild
new file mode 100644
index 000000000000..95bdbd6fd5f6
--- /dev/null
+++ b/sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.30.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune findlib
+
+DESCRIPTION="FUSE filesystem over Google Drive"
+HOMEPAGE="
+ https://github.com/astrada/google-drive-ocamlfuse
+ https://opam.ocaml.org/packages/google-drive-ocamlfuse/
+"
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="
+ >=dev-ml/gapi-ocaml-0.4.2:=
+ >=dev-ml/ocamlfuse-2.7.1:=
+ dev-ml/cryptokit:=
+ dev-ml/extlib:=
+ dev-ml/ocaml-sqlite3:=
+ >=dev-ml/tiny_httpd-0.6:=
+"
+DEPEND="
+ ${RDEPEND}
+ dev-ml/camlidl:=
+ test? ( dev-ml/ounit2 )
+"
+
+RESTRICT="!test? ( test )"