summaryrefslogtreecommitdiff
path: root/sys-fs/fswatch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/fswatch')
-rw-r--r--sys-fs/fswatch/Manifest3
-rw-r--r--sys-fs/fswatch/fswatch-1.16.0.ebuild27
-rw-r--r--sys-fs/fswatch/metadata.xml7
3 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/fswatch/Manifest b/sys-fs/fswatch/Manifest
new file mode 100644
index 000000000000..8de9c755cfaf
--- /dev/null
+++ b/sys-fs/fswatch/Manifest
@@ -0,0 +1,3 @@
+DIST fswatch-1.16.0.tar.gz 844804 BLAKE2B 55527e7d38421f16a9d2c51b5455b73de54220d280233d905a02d192bc374ef91b02c0d68dcd1c1ed6a29351421df0cd0ee9fad50bb98ec9c9018088a6064d4b SHA512 80100b92f5acef503436bbb684f07f5b692099a7eee0970a61c04670de67cd9bfa7942af40b348236dd97fc4d02fcd6a081b96486332efbd06500379c1eff806
+EBUILD fswatch-1.16.0.ebuild 603 BLAKE2B c7c856a4bafb3f92d504b6bea4884895e1c8b6800eafbab8e1cea2ecb03d3b5a5f401ddaf2d815fe6d0ff2dec3fbaf91d2d74692950df55ad140917d7a1ff104 SHA512 7bf6b555a175bdccf126e410ff28028b99ec41b745d547a94dc63cf89fa178cb31d862a641d7fda0222fd006ff5f915520049731a6a1176e726696b3ffcc96b3
+MISC metadata.xml 216 BLAKE2B 921055d990617104de7e3437bc9fd4598cb830193bfcdc34254102a1df2c6025916af7025843f161dff8de731f9726641906b86f831375c5d29303ba64991da2 SHA512 8c43f5f2be76799c8ace4df222de22380c389e058bc7e36bd9b19564cbd4b90ab7515b90f822139a18b3a2cba70e76d3b4eb5426f88a0508798175893073d732
diff --git a/sys-fs/fswatch/fswatch-1.16.0.ebuild b/sys-fs/fswatch/fswatch-1.16.0.ebuild
new file mode 100644
index 000000000000..f145c182b0f7
--- /dev/null
+++ b/sys-fs/fswatch/fswatch-1.16.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="cross-platform file change monitor with multiple backends"
+HOMEPAGE="https://github.com/emcrisostomo/fswatch"
+SRC_URI="https://github.com/emcrisostomo/${PN}/releases/download/${PV}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="nls static-libs"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ CXX=$(tc-getCXX)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/sys-fs/fswatch/metadata.xml b/sys-fs/fswatch/metadata.xml
new file mode 100644
index 000000000000..91e8ad9f5e33
--- /dev/null
+++ b/sys-fs/fswatch/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ada@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>