summaryrefslogtreecommitdiff
path: root/sys-fs/duperemove/duperemove-0.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/duperemove/duperemove-0.13.ebuild')
-rw-r--r--sys-fs/duperemove/duperemove-0.13.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fs/duperemove/duperemove-0.13.ebuild b/sys-fs/duperemove/duperemove-0.13.ebuild
new file mode 100644
index 000000000000..82e6d1da0fdb
--- /dev/null
+++ b/sys-fs/duperemove/duperemove-0.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Btrfs and xfs deduplication utility"
+HOMEPAGE="https://github.com/markfasheh/duperemove/"
+SRC_URI="
+ https://github.com/markfasheh/duperemove/archive/v${PV/_/.}.tar.gz
+ -> ${P/_/.}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P/_/.}
+
+src_compile() {
+ emake VERSION="${PV}" IS_RELEASE=1 CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}