summaryrefslogtreecommitdiff
path: root/sys-fs/duperemove/duperemove-0.11.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/duperemove/duperemove-0.11.3.ebuild')
-rw-r--r--sys-fs/duperemove/duperemove-0.11.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/duperemove/duperemove-0.11.3.ebuild b/sys-fs/duperemove/duperemove-0.11.3.ebuild
new file mode 100644
index 000000000000..116961235a22
--- /dev/null
+++ b/sys-fs/duperemove/duperemove-0.11.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Btrfs and xfs deduplication utility"
+HOMEPAGE="https://github.com/markfasheh/duperemove"
+SRC_URI="https://github.com/markfasheh/duperemove/archive/v${PV/_/.}.tar.gz -> ${P/_/.}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P/_/.}
+
+src_prepare() {
+ sed -i -e "/VER/s:0.12.dev:${PV}:" Makefile || die
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}