summaryrefslogtreecommitdiff
path: root/sys-freebsd/freebsd-ubin/freebsd-ubin-11.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-freebsd/freebsd-ubin/freebsd-ubin-11.0-r1.ebuild')
-rw-r--r--sys-freebsd/freebsd-ubin/freebsd-ubin-11.0-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-freebsd/freebsd-ubin/freebsd-ubin-11.0-r1.ebuild b/sys-freebsd/freebsd-ubin/freebsd-ubin-11.0-r1.ebuild
index 7c9aac54f997..bf7da86b52e6 100644
--- a/sys-freebsd/freebsd-ubin/freebsd-ubin-11.0-r1.ebuild
+++ b/sys-freebsd/freebsd-ubin/freebsd-ubin-11.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -108,8 +108,8 @@ pkg_preinst() {
# bison installs a /usr/bin/yacc symlink ...
# we need to remove it to avoid triggering
# collision-protect errors
- if [[ -L ${ROOT}/usr/bin/yacc ]] ; then
- rm -f "${ROOT}"/usr/bin/yacc
+ if [[ -L ${ROOT}/usr/bin/yacc ]]; then
+ rm -f "${ROOT}"/usr/bin/yacc || die
fi
}
@@ -123,7 +123,7 @@ src_prepare() {
# Rename manpage for renamed ar
mv "${S}"/ar/ar.1 "${S}"/ar/freebsd-ar.1 || die
# Fix whereis(1) manpath search.
- sed -i -e 's:"manpath -q":"manpath":' "${S}/whereis/pathnames.h"
+ sed -i -e 's:"manpath -q":"manpath":' "${S}/whereis/pathnames.h" || die
# Build a dynamic make
sed -i -e '/^NO_SHARED/ s/^/#/' "${S}"/bmake/Makefile.inc || die
@@ -148,7 +148,7 @@ setup_multilib_vars() {
src_compile() {
local MULTIBUILD_VARIANTS="${DEFAULT_ABI}"
# Preparing to build addr2line, elfcopy, m4
- for dir in libelftc libpe libopenbsd ; do
+ for dir in libelftc libpe libopenbsd; do
cd "${WORKDIR}/lib/${dir}" || die
multibuild_foreach_variant freebsd_multilib_multibuild_wrapper freebsd_src_compile -j1
done
@@ -168,7 +168,7 @@ src_install() {
# baselayout requires these in /bin
dodir /bin
- for bin in sed printf ; do
+ for bin in sed printf; do
mv "${D}/usr/bin/${bin}" "${D}/bin/" || die "mv ${bin} failed"
dosym /bin/${bin} /usr/bin/${bin} || die "dosym ${bin} failed"
done
@@ -198,7 +198,7 @@ pkg_postinst() {
# We need to ensure that login.conf.db is up-to-date.
if [[ -e "${ROOT}"etc/login.conf ]] ; then
einfo "Updating ${ROOT}etc/login.conf.db"
- "${ROOT}"usr/bin/cap_mkdb -f "${ROOT}"etc/login.conf "${ROOT}"etc/login.conf
+ "${ROOT}"usr/bin/cap_mkdb -f "${ROOT}"etc/login.conf "${ROOT}"etc/login.conf || die
elog "Remember to run cap_mkdb /etc/login.conf after making changes to it"
fi
}
@@ -207,6 +207,6 @@ pkg_postrm() {
# and if we uninstall yacc but keep bison,
# lets restore the /usr/bin/yacc symlink
if [[ ! -e ${ROOT}/usr/bin/yacc ]] && [[ -e ${ROOT}/usr/bin/yacc.bison ]] ; then
- ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc || die
fi
}