summaryrefslogtreecommitdiff
path: root/sys-freebsd/freebsd-sources/files/freebsd-sources-11.0-gentoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-freebsd/freebsd-sources/files/freebsd-sources-11.0-gentoo.patch')
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-11.0-gentoo.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-11.0-gentoo.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-11.0-gentoo.patch
new file mode 100644
index 000000000000..6acd6aab3608
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-11.0-gentoo.patch
@@ -0,0 +1,22 @@
+diff --git a/sys/conf/kern.mk b/sys/conf/kern.mk
+index e27ea93..615dbac 100644
+--- a/sys/conf/kern.mk
++++ b/sys/conf/kern.mk
+@@ -5,7 +5,7 @@
+ #
+ CWARNFLAGS?= -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes \
+ -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual \
+- -Wundef -Wno-pointer-sign ${FORMAT_EXTENSIONS} \
++ -Wundef -Wno-pointer-sign \
+ -Wmissing-include-dirs -fdiagnostics-show-option \
+ -Wno-unknown-pragmas \
+ ${CWARNEXTRA}
+@@ -86,7 +86,7 @@ FORMAT_EXTENSIONS= -fformat-extensions
+ # Setting -mno-sse implies -mno-sse2, -mno-sse3, -mno-ssse3, -mno-sse41 and -mno-sse42
+ #
+ .if ${MACHINE_CPUARCH} == "i386"
+-CFLAGS.gcc+= -mno-align-long-strings -mpreferred-stack-boundary=2
++CFLAGS.gcc+= -mpreferred-stack-boundary=2
+ CFLAGS.clang+= -mno-aes -mno-avx
+ CFLAGS+= -mno-mmx -mno-sse -msoft-float
+ INLINE_LIMIT?= 8000