summaryrefslogtreecommitdiff
path: root/sys-firmware
diff options
context:
space:
mode:
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/Manifest.gzbin5031 -> 5038 bytes
-rw-r--r--sys-firmware/edk2-ovmf/Manifest2
-rw-r--r--sys-firmware/edk2-ovmf/edk2-ovmf-2017_pre20170505-r1.ebuild116
-rw-r--r--sys-firmware/edk2-ovmf/edk2-ovmf-9999.ebuild116
-rw-r--r--sys-firmware/seabios/Manifest2
-rw-r--r--sys-firmware/seabios/seabios-1.10.2.ebuild2
6 files changed, 236 insertions, 2 deletions
diff --git a/sys-firmware/Manifest.gz b/sys-firmware/Manifest.gz
index d0dc9670207f..a14c03d7447d 100644
--- a/sys-firmware/Manifest.gz
+++ b/sys-firmware/Manifest.gz
Binary files differ
diff --git a/sys-firmware/edk2-ovmf/Manifest b/sys-firmware/edk2-ovmf/Manifest
index b2aa667aaf51..0cf3ceab80f1 100644
--- a/sys-firmware/edk2-ovmf/Manifest
+++ b/sys-firmware/edk2-ovmf/Manifest
@@ -1,5 +1,7 @@
AUX edk2-ovmf-2017_pre20170505-build_system_fixes.patch 20014 BLAKE2B e2dc20057ef58698e88a9b971eea921f0e5833fb24605f99bb109527283762893bb0271eaa16200c1d26c58024d72dfe1bd1636b55522c8147a69796ba1fa0d4 SHA512 3db1adcabd1e2446c601a52da7e52b4b89323e329dc852c568320e9fb3e8a4619ad8aeda1b529022cd20c7af77894221cca5c34c7acd73115dcb083991216150
DIST edk2-ovmf-2017_pre20170505-bin.tar.xz 874904 BLAKE2B a381d3ca20cf0e1f3aff74335c1d783bb80f0b5c7a8716d8154f2e0a19255780e5b08fae37cab9fa484fc1cbe3bc3b5d40339634ee3b0808bd2b3a8b2849730a SHA512 c7a7d83758214b6ab63c6cefe827a601aaa7656b7f01e03413c84d913078a2b0d8037f70de34d42d8e1614aee794e0ffd7d9e62314eb4e04c21256b70338af5c
DIST edk2-ovmf-2017_pre20170505.tar.xz 22952060 BLAKE2B 7d4da1fed8e76f643e2856be2485f6c398896d61b7ad8fb013e891fd73f69c4acfd9980e7f95aec002cee647719a622711100f8cb6829edecae35ed31b3ef563 SHA512 6da859360448fd6d04d1492c88a7e935f7108c524f7ccfe6aa4c13bf9af9695dbc4a5b8efa274adc86d3105946aaa1ba80bcd9713facdca153f1a3d873797b63
+EBUILD edk2-ovmf-2017_pre20170505-r1.ebuild 2627 BLAKE2B 0dfddc2ae12ff8bd393665de077922173a6f2d21e746cf02dd242d664d2b0a5b17f06f44f4b2724bc576fd233ea3365b1a587ef245a947e01138fce7db4e48d4 SHA512 e6963311f3223368dbc8a8031c1ac002fd5398433720d48e1e6179534cfae476a3365b9f498c3e134947e2b6e89b818ae0b31c8f6c111970fa548a0e0a3eabdb
EBUILD edk2-ovmf-2017_pre20170505.ebuild 2447 BLAKE2B 736d34ddd458b35b88da04ed202213061c6a7e82b095aeb7dc3c7a159ad021ea9f6deb3e5f927ce40acfec4268462db898e4f4b4a2824b8bc2f3875bda3acf1a SHA512 d78c894492931070e55cfd92eec95450ea619ea734da2bc63f3f106aacf437d020359acda9902a7abb83526c87ca7270f11aac48be6c8f142a4a9ba96d473707
+EBUILD edk2-ovmf-9999.ebuild 2623 BLAKE2B d45f009e190c4b3509f0e964b0b543b7b1cd151f16d36c15521c20f4eae706222817feaa938d9f6f09bbb53273f3eb4c08a63626c5b1e388a9c081ca7de7b9c9 SHA512 ea78ca3f82f628372886736f596b768982a192dd78397ab085ac0b985a00c3452b2b33c5aa17b0e162e2f470d968ff2714ec12f8a7572a10e4857a095da2b9b3
MISC metadata.xml 435 BLAKE2B b33371654b280e097ad5d112081f115446cb01a0efcf3e712bcad7e5a51d95b77f55d0e218c4767803675b71d24b405616849f57051fda492acf5d3c0e8fd1dc SHA512 d1e6233650fc1ea3a25bead14091877b9f507d2bc78cec6436e1b6e17477e40517b74da66e26b6bd39259e4ca308d724324296f1a6c353fed2f8bf112029b90f
diff --git a/sys-firmware/edk2-ovmf/edk2-ovmf-2017_pre20170505-r1.ebuild b/sys-firmware/edk2-ovmf/edk2-ovmf-2017_pre20170505-r1.ebuild
new file mode 100644
index 000000000000..5dc75dbd084c
--- /dev/null
+++ b/sys-firmware/edk2-ovmf/edk2-ovmf-2017_pre20170505-r1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-any-r1 readme.gentoo-r1
+
+DESCRIPTION="UEFI firmware for 64-bit x86 virtual machines"
+HOMEPAGE="https://github.com/tianocore/edk2"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+NON_BINARY_DEPEND="
+ >=dev-lang/nasm-2.0.7
+ >=sys-power/iasl-20160729
+ ${PYTHON_DEPS}
+"
+DEPEND=""
+RDEPEND=""
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tianocore/edk2"
+ DEPEND+="
+ ${NON_BINARY_DEPEND}
+ "
+else
+ SRC_URI="
+ binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}-bin.tar.xz )
+ !binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}.tar.xz )"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+ IUSE="+binary"
+ REQUIRED_USE+="
+ !amd64? ( binary )
+ "
+ DEPEND+="
+ !binary? (
+ amd64? (
+ ${NON_BINARY_DEPEND}
+ )
+ )"
+ PATCHES=(
+ "${FILESDIR}"/${P}-build_system_fixes.patch
+ )
+fi
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+
+DISABLE_AUTOFORMATTING=true
+DOC_CONTENTS="This package contains the tianocore edk2 UEFI firmware for 64-bit x86
+virtual machines. The firmware is located under
+ /usr/share/edk2-ovmf/OVMF.fd
+ /usr/share/edk2-ovmf/OVMF_CODE.fd
+ /usr/share/edk2-ovmf/OVMF_VARS.fd
+
+The firmware does not support csm (due to no free csm implementation
+available). If you need a firmware with csm support you have to download
+one for yourself. Firmware blobs are commonly labeled
+ OVMF{,_CODE,_VARS}-with-csm.fd
+
+In order to use the firmware you can run qemu the following way
+
+ $ qemu-system-x86_64 \
+ -drive file=/usr/share/edk2-ovmf/OVMF.fd,if=pflash,format=raw,unit=0,readonly=on \
+ ...
+
+You can register the firmware for use in libvirt by adding to /etc/libvirt/qemu.conf:
+ nvram = [
+ \"/usr/share/edk2-ovmf/OVMF_CODE.fd:/usr/share/edk2-ovmf/OVMF_VARS.fd\"
+ ]"
+
+pkg_setup() {
+ [[ ${PV} != "9999" ]] && use binary || python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if [[ ${PV} != "9999" ]] && use binary; then
+ eapply_user
+ return
+ fi
+ default
+}
+
+src_compile() {
+ TARGET_ARCH=X64
+ TARGET_NAME=RELEASE
+ TARGET_TOOLS=GCC49
+
+ [[ ${PV} != "9999" ]] && use binary && return
+
+ emake ARCH=${TARGET_ARCH} -C BaseTools -j1
+
+ . ./edksetup.sh
+
+ ./OvmfPkg/build.sh \
+ -a "${TARGET_ARCH}" -b "${TARGET_NAME}" -t "${TARGET_TOOLS}" \
+ -D FD_SIZE_2MB \
+ || die "OvmfPkg/build.sh failed"
+}
+
+src_install() {
+ local builddir="Build/OvmfX64/${TARGET_NAME}_${TARGET_TOOLS}/FV"
+
+ insinto /usr/share/${PN}
+ doins "${builddir}"/OVMF{,_CODE,_VARS}.fd
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/sys-firmware/edk2-ovmf/edk2-ovmf-9999.ebuild b/sys-firmware/edk2-ovmf/edk2-ovmf-9999.ebuild
new file mode 100644
index 000000000000..9fc2de7937d9
--- /dev/null
+++ b/sys-firmware/edk2-ovmf/edk2-ovmf-9999.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-any-r1 readme.gentoo-r1
+
+DESCRIPTION="UEFI firmware for 64-bit x86 virtual machines"
+HOMEPAGE="https://github.com/tianocore/edk2"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+NON_BINARY_DEPEND="
+ >=dev-lang/nasm-2.0.7
+ >=sys-power/iasl-20160729
+ ${PYTHON_DEPS}
+"
+DEPEND=""
+RDEPEND=""
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tianocore/edk2"
+ DEPEND+="
+ ${NON_BINARY_DEPEND}
+ "
+else
+ SRC_URI="
+ binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}-bin.tar.xz )
+ !binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}.tar.xz )"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+ IUSE="+binary"
+ REQUIRED_USE+="
+ !amd64? ( binary )
+ "
+ DEPEND+="
+ !binary? (
+ amd64? (
+ ${NON_BINARY_DEPEND}
+ )
+ )"
+ PATCHES=(
+ "${FILESDIR}"/${P}-build_system_fixes.patch
+ )
+fi
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+
+DISABLE_AUTOFORMATTING=true
+DOC_CONTENTS="This package contains the tianocore edk2 UEFI firmware for 64-bit x86
+virtual machines. The firmware is located under
+ /usr/share/edk2-ovmf/OVMF.fd
+ /usr/share/edk2-ovmf/OVMF_CODE.fd
+ /usr/share/edk2-ovmf/OVMF_VARS.fd
+
+The firmware does not support csm (due to no free csm implementation
+available). If you need a firmware with csm support you have to download
+one for yourself. Firmware blobs are commonly labeled
+ OVMF{,_CODE,_VARS}-with-csm.fd
+
+In order to use the firmware you can run qemu the following way
+
+ $ qemu-system-x86_64 \
+ -drive file=/usr/share/edk2-ovmf/OVMF.fd,if=pflash,format=raw,unit=0,readonly=on \
+ ...
+
+You can register the firmware for use in libvirt by adding to /etc/libvirt/qemu.conf:
+ nvram = [
+ \"/usr/share/edk2-ovmf/OVMF_CODE.fd:/usr/share/edk2-ovmf/OVMF_VARS.fd\"
+ ]"
+
+pkg_setup() {
+ [[ ${PV} != "9999" ]] && use binary || python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if [[ ${PV} != "9999" ]] && use binary; then
+ eapply_user
+ return
+ fi
+ default
+}
+
+src_compile() {
+ TARGET_ARCH=X64
+ TARGET_NAME=RELEASE
+ TARGET_TOOLS=GCC49
+
+ [[ ${PV} != "9999" ]] && use binary && return
+
+ emake ARCH=${TARGET_ARCH} -C BaseTools
+
+ . ./edksetup.sh
+
+ ./OvmfPkg/build.sh \
+ -a "${TARGET_ARCH}" -b "${TARGET_NAME}" -t "${TARGET_TOOLS}" \
+ -D FD_SIZE_2MB \
+ || die "OvmfPkg/build.sh failed"
+}
+
+src_install() {
+ local builddir="Build/OvmfX64/${TARGET_NAME}_${TARGET_TOOLS}/FV"
+
+ insinto /usr/share/${PN}
+ doins "${builddir}"/OVMF{,_CODE,_VARS}.fd
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/sys-firmware/seabios/Manifest b/sys-firmware/seabios/Manifest
index 1e494043ea48..9a96f36db941 100644
--- a/sys-firmware/seabios/Manifest
+++ b/sys-firmware/seabios/Manifest
@@ -14,5 +14,5 @@ DIST seabios-1.10.2-bin.tar.xz 121172 BLAKE2B 9d4ff624b638773e59bbf6674fb8630bd8
DIST seabios-1.10.2.tar.gz 589283 BLAKE2B 08fdbecf7fb06629db472adb05a780249dbf0e0a44d04dcced5480d631c133f74ecd04b04486db3bb817b8e119e783c4b09c3ade15b9a6cc956537e9f7204514 SHA512 ea8396fe247a3bd16b43ab775cf8e23f139673b94e83f450cadb094cc8117ca7e9ef518162d965209d5ab091c96f70ec5cc8ec8d15b638e06c4c8f7a0e1609dc
DIST seavgabios-bin-1.10.1.tar.xz 20408 BLAKE2B e8678a5e1b7cf5c36017c3f3dec1996103304394215ce52e9fc23bb0581d253a87be0592eb5b2f1ef7bbfb03e80cd937d82b04a46c76e41fa5b95063782075b2 SHA512 7fe97efaf61c2d1e72c8df27b5108c80f6a51f5a7370de68720b0f71abe05ae5765dd867d127df2fa6182b5d4702a9ef7549e7170fec5071b31a6066db20c219
EBUILD seabios-1.10.1.ebuild 3444 BLAKE2B 899b2f0c7804c76a4ec30796dbc242fc6d89f7686291073a351eaf5ad4f5e6685d3ec81a184ca4436aff36737ebff370d487799a4001f05f71d1a5fe02749b77 SHA512 6344ad74bebcb1752221d26fd22905a37ed3e4e70836f2916677088dc3add02546a423f4e97b49d9a837de9882d888dfb3dd5b49f249c2e0e0f9bff62fda7b69
-EBUILD seabios-1.10.2.ebuild 3409 BLAKE2B f99a37c79a48a3b2547a7dd33c2222dab7982362c81e92cd7ad283bab5edcf5192321f904be37bab20640369e1b6dfacbb8a87fef1cc4cdedd481a0d39bf2706 SHA512 256ea6d7a2ebd861affe1f9dc5f8e02b7e0fd90cfb82433bcf24e419e2644a540d9b51d8ecc1db3e659b7bbe0170f58f6c878436214c32c04710fd055dd8dbfe
+EBUILD seabios-1.10.2.ebuild 3411 BLAKE2B 60be808fdaa681aad580615c077896eb32cc0138207f56bf474fa93dfef80bdcda875e7757f242d5f01a3796857a036b8f81c2f71ee97fc3b7081101e4a6fcb6 SHA512 c1dd401ea38f1c4479d7c0c7436e13ac83288f0fa21b3ea368389b5b9dbda14d63ce319d92c6ea7a03c6efef9dd0d126691efa4d79f36c9d730f52cba85befb7
MISC metadata.xml 663 BLAKE2B 54437b23d3d5ac74acee9b057e094c67db93d6b593367401d56e1b60a126a67ad9481ce15ffef0c004e2b554e90806e69bb7838594557fd36e461fb7c6a7cd09 SHA512 a3b306f0cfc8d0c2f31757b3b141c532dc5ee1fea7c01b7d23e6643977e63aee90a007875f1e34fb3f212c2dc1e23e4400f092b1d288f325abead33a9cfa66fa
diff --git a/sys-firmware/seabios/seabios-1.10.2.ebuild b/sys-firmware/seabios/seabios-1.10.2.ebuild
index d1513a29956f..d06e51b40a0b 100644
--- a/sys-firmware/seabios/seabios-1.10.2.ebuild
+++ b/sys-firmware/seabios/seabios-1.10.2.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
inherit eutils toolchain-funcs python-any-r1