summaryrefslogtreecommitdiff
path: root/sys-fabric/mstflint/mstflint-4.13.3_p2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fabric/mstflint/mstflint-4.13.3_p2.ebuild')
-rw-r--r--sys-fabric/mstflint/mstflint-4.13.3_p2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fabric/mstflint/mstflint-4.13.3_p2.ebuild b/sys-fabric/mstflint/mstflint-4.13.3_p2.ebuild
new file mode 100644
index 000000000000..35f63adf6dac
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.13.3_p2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="0c3327f6bf037878d4ccc47fd46740adfc0c220e"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="https://github.com/Mellanox/mstflint/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="inband ssl"
+SLOT="0"
+RDEPEND="dev-db/sqlite:3=
+ sys-libs/zlib:=
+ inband? ( sys-fabric/libibmad )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband) $(use_enable ssl openssl)
+}