summaryrefslogtreecommitdiff
path: root/sys-devel/sparse
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/Manifest1
-rw-r--r--sys-devel/sparse/files/sparse-0.5.1-cmdline-include.patch66
2 files changed, 0 insertions, 67 deletions
diff --git a/sys-devel/sparse/Manifest b/sys-devel/sparse/Manifest
index cc021330df86..66e9b8e922a0 100644
--- a/sys-devel/sparse/Manifest
+++ b/sys-devel/sparse/Manifest
@@ -1,4 +1,3 @@
-AUX sparse-0.5.1-cmdline-include.patch 1886 BLAKE2B 328a414d8c24f02e682978b7b6fef225519f5c5036ebb6f052dc930536ceb7232dfd45ccd158eaa712d2c4c1c622261969c24703bf4b69d6b625c0be4d397204 SHA512 d4267e94d7603b421a1df09869706114b5f81867ddd1d758b1dd251232f645e4a0c14df1d2bb993c78d14afaa699f84f7754b62fae19d1ccabe28571550d92f7
DIST sparse-0.6.1.tar.xz 287880 BLAKE2B 026e7770460ab576b91e8c401c642e95269ddd7c90c0f855b0246448ca653b95a899b4bf647134c090c06c802757b6415dcc89bc214fb7ff124c2ce3888fccb0 SHA512 2faad9b3263f19f941cd6a5891960d2c7d1066c664d3ef68e722d461785aeed2d4a9539df3556bbd98c022e7ee965b8030c49272ab6003113ba3b36f73c00187
EBUILD sparse-0.6.1.ebuild 1371 BLAKE2B 1cb48cddc186f3ab6726c5d7d6f4dcd680e44856626abe1cf1df61c4dbaa65f1bb821422533ec37e658be1330605cfb22f72461a7378dd7e561359c5c454f047 SHA512 cd3ac75ad44361a400cc659fe4e6b40da0bd10db5ec2e9cc96811d11002bfede6e345888cf662dac6963b9f7713b7068cefac19aee412cde699250770d9226e5
EBUILD sparse-9999.ebuild 1371 BLAKE2B 1cb48cddc186f3ab6726c5d7d6f4dcd680e44856626abe1cf1df61c4dbaa65f1bb821422533ec37e658be1330605cfb22f72461a7378dd7e561359c5c454f047 SHA512 cd3ac75ad44361a400cc659fe4e6b40da0bd10db5ec2e9cc96811d11002bfede6e345888cf662dac6963b9f7713b7068cefac19aee412cde699250770d9226e5
diff --git a/sys-devel/sparse/files/sparse-0.5.1-cmdline-include.patch b/sys-devel/sparse/files/sparse-0.5.1-cmdline-include.patch
deleted file mode 100644
index 5ea763001a05..000000000000
--- a/sys-devel/sparse/files/sparse-0.5.1-cmdline-include.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/validation/include-eval.c b/validation/include-eval.c
-new file mode 100644
-index 000000000..bf9bf63fe
---- /dev/null
-+++ b/validation/include-eval.c
-@@ -0,0 +1,7 @@
-+/* nothing */
-+
-+/*
-+ * check-name: include-eval.c
-+ * check-command: sparse -include ./include-eval.inc $file
-+ * check-known-to-fail
-+ */
-diff --git a/validation/include-eval.inc b/validation/include-eval.inc
-new file mode 100644
-index 000000000..e2561ca41
---- /dev/null
-+++ b/validation/include-eval.inc
-@@ -0,0 +1,12 @@
-+typedef unsigned long long_t;
-+
-+inline
-+static unsigned int ok(void)
-+{
-+ return sizeof(long_t);
-+}
-+
-+static unsigned int ko(void)
-+{
-+ return sizeof(long_t);
-+}
-diff --git a/lib.c b/lib.c
-index 4602cf85d..b255fec14 100644
---- a/lib.c
-+++ b/lib.c
-@@ -1351,6 +1351,20 @@ struct symbol_list *sparse_initialize(int argc, char **argv, struct string_list
- */
- protect_token_alloc();
- }
-+ /*
-+ * Evaluate the complete symbol list
-+ * Note: This is not needed for normal cases.
-+ * These symbols should only be predefined defines and
-+ * declaratons which will be evaluated later, when needed.
-+ * This is also the case when a file is directly included via
-+ * '-include <file>' on the command line *AND* the file only
-+ * contains defines, declarations and inline definitions.
-+ * However, in the rare cases where the given file should
-+ * contain some definitions, these will never be evaluated
-+ * and thus won't be able to be linearized correctly.
-+ * Hence the evaluate_symbol_list() here under.
-+ */
-+ evaluate_symbol_list(list);
- return list;
- }
-
-diff --git a/validation/include-eval.c b/validation/include-eval.c
-index bf9bf63fe..1a91dab84 100644
---- a/validation/include-eval.c
-+++ b/validation/include-eval.c
-@@ -3,5 +3,4 @@
- /*
- * check-name: include-eval.c
- * check-command: sparse -include ./include-eval.inc $file
-- * check-known-to-fail
- */