summaryrefslogtreecommitdiff
path: root/sys-devel/slibtool/slibtool-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/slibtool/slibtool-9999.ebuild')
-rw-r--r--sys-devel/slibtool/slibtool-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-devel/slibtool/slibtool-9999.ebuild b/sys-devel/slibtool/slibtool-9999.ebuild
index 200a19a514d4..5295be737954 100644
--- a/sys-devel/slibtool/slibtool-9999.ebuild
+++ b/sys-devel/slibtool/slibtool-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -32,6 +32,7 @@ src_configure() {
--compiler="$(tc-getCC)" \
--host=${CHOST} \
--prefix="${EPREFIX}"/usr \
- --libdir="$(get_libdir)" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --shell="${EPREFIX}"/bin/sh \
|| die
}