summaryrefslogtreecommitdiff
path: root/sys-devel/parity
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/parity')
-rw-r--r--sys-devel/parity/Manifest3
-rw-r--r--sys-devel/parity/parity-2.0.1.ebuild6
-rw-r--r--sys-devel/parity/parity-9999.ebuild77
3 files changed, 4 insertions, 82 deletions
diff --git a/sys-devel/parity/Manifest b/sys-devel/parity/Manifest
index 85cff33510cb..4af5fd881dc7 100644
--- a/sys-devel/parity/Manifest
+++ b/sys-devel/parity/Manifest
@@ -1,4 +1,3 @@
DIST parity-2.0.1.tar.bz2 371662 BLAKE2B c0fca272665bbe346d5d5ca18e06c65209df61454310811b939239f8ba25ec7a08ad2f864fb43780329dc1f0120afdb6ea4ee2b4b42d2888860358aa1dc176f4 SHA512 3c96c87b87f40cb7affd6ee9a87c8e7cf628aedb44a2d3d89370a5b5e32a43cb15a897ae27425e9d6a00581ffd50a70c7a7481f1ca259eddd1e6f2310b554eb9
-EBUILD parity-2.0.1.ebuild 1824 BLAKE2B 6fb12910df5fdbf5e17bca54983739e6d72fb21975399e1d0f867c26be13a14e0511fc5fbab15fd5db49d4de7b010a1a27e2b7a4871b5558f209793a15a6237b SHA512 f17caa80b6115de5f362a0193d515118836c0d491e87ac8c2520dc453d2a7d45127dbdbb0e82f442bb2a32005fe747289d0320d0fd2bac6a103f26093a170d52
-EBUILD parity-9999.ebuild 1824 BLAKE2B 6fb12910df5fdbf5e17bca54983739e6d72fb21975399e1d0f867c26be13a14e0511fc5fbab15fd5db49d4de7b010a1a27e2b7a4871b5558f209793a15a6237b SHA512 f17caa80b6115de5f362a0193d515118836c0d491e87ac8c2520dc453d2a7d45127dbdbb0e82f442bb2a32005fe747289d0320d0fd2bac6a103f26093a170d52
+EBUILD parity-2.0.1.ebuild 1838 BLAKE2B a001b741ef41030ce4f802b68a170adcfadb755085865a388788b077514e6ba7b799f5f4674eb8947c8cfe36567c85bdea99accba191a598a4bcdc25204289e7 SHA512 ce2c481baf5d20aa413ae8de7e88063b2c2dd8b14498f86757d951b3e1cd4b1cc6f58f6619d0b24e6a919316936378b649fbc16927fbedf46777b5a5bf892420
MISC metadata.xml 951 BLAKE2B 220c8e7b21103b6a3ba4c044e3eb45b5f18d78aac6ed23d967c36c33383d1b927dde458cb02c211f276b8e154d17011a37cf8b696d7fd35ff50ade027373d2df SHA512 9d7262935aad1af1a099faf9d8ba1b40af956d2e090cb7668f2382afcc8d0fadb46ca7169cb0055ccb1fe8e73e36cec8fb2ada6125326b9092df3bb2b51b4065
diff --git a/sys-devel/parity/parity-2.0.1.ebuild b/sys-devel/parity/parity-2.0.1.ebuild
index a6d5f5cfc4aa..3de370518ab4 100644
--- a/sys-devel/parity/parity-2.0.1.ebuild
+++ b/sys-devel/parity/parity-2.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,11 +8,11 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="git@github.com:ssi-schaefer/parity.git https://github.com/ssi-schaefer/parity.git"
BDEPEND="dev-util/confix"
else
- SRC_URI="https://github.com/mduft/${PN}/releases/download/${PV}/${P}.tar.bz2"
+ SRC_URI="https://github.com/ssi-schaefer/${PN}/releases/download/${PV}/${P}.tar.bz2"
KEYWORDS="~x64-cygwin"
fi
DESCRIPTION="A POSIX to native Win32 Cross-Compiler Tool (requires Visual Studio)"
-HOMEPAGE="https://github.com/mduft/parity"
+HOMEPAGE="https://github.com/ssi-schaefer/parity"
parity-vcarchs() { echo x64=x86_64 x86=i686 ; }
parity-vcvers-legacy() { echo 8_0 9_0 ; }
diff --git a/sys-devel/parity/parity-9999.ebuild b/sys-devel/parity/parity-9999.ebuild
deleted file mode 100644
index a6d5f5cfc4aa..000000000000
--- a/sys-devel/parity/parity-9999.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} == 9999 ]]; then
- inherit autotools git-r3
- EGIT_REPO_URI="git@github.com:ssi-schaefer/parity.git https://github.com/ssi-schaefer/parity.git"
- BDEPEND="dev-util/confix"
-else
- SRC_URI="https://github.com/mduft/${PN}/releases/download/${PV}/${P}.tar.bz2"
- KEYWORDS="~x64-cygwin"
-fi
-DESCRIPTION="A POSIX to native Win32 Cross-Compiler Tool (requires Visual Studio)"
-HOMEPAGE="https://github.com/mduft/parity"
-
-parity-vcarchs() { echo x64=x86_64 x86=i686 ; }
-parity-vcvers-legacy() { echo 8_0 9_0 ; }
-parity-vcvers-current() { echo 10_0 11_0 12_0 14_0 15 16 ; }
-parity-vcvers() {
- parity-vcvers-legacy
- parity-vcvers-current
-}
-
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="$(
- for a in $(parity-vcarchs); do echo "+vc${a%=*}"; done
- for v in $(parity-vcvers-legacy); do echo "vc${v}"; done
- for v in $(parity-vcvers-current); do echo "+vc${v}"; done
-)"
-
-if [[ ${PV} == 9999 ]]; then
- src_prepare() {
- default
- confix --output || die
- eautoreconf
- }
-fi
-
-parity-enabled-vcarchs() {
- local enabled= a
- for a in $(parity-vcarchs) ; do
- if use vc${a%=*} ; then
- enabled+=",${a#*=}"
- fi
- done
- echo ${enabled#,}
-}
-
-parity-enabled-vcvers() {
- local enabled= v
- for v in $(parity-vcvers) ; do
- if use vc${v} ; then
- enabled+=",${v/_/.}"
- fi
- done
- echo ${enabled#,}
-}
-
-src_configure() {
- local myconf=(
- --enable-msvc-archs="$(parity-enabled-vcarchs)"
- --enable-msvc-versions="$(parity-enabled-vcvers)"
- --disable-default-msvc-version
- )
- econf "${myconf[@]}"
-}
-
-pkg_postinst() {
- if [[ -n ${ROOT} ]] ; then
- einfo "To enable all available MSVC versions, on the target machine please run:"
- einfo " '${EPREFIX}/usr/bin/parity-setup' --enable-all"
- else
- "${EPREFIX}"/usr/bin/parity-setup --enable-all
- fi
-}