summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-9.0.1.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-9.0.1.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9.0.1.9999.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/sys-devel/llvm/llvm-9.0.1.9999.ebuild b/sys-devel/llvm/llvm-9.0.1.9999.ebuild
index 5ff9e20d7e12..2f2597f5b16d 100644
--- a/sys-devel/llvm/llvm-9.0.1.9999.ebuild
+++ b/sys-devel/llvm/llvm-9.0.1.9999.ebuild
@@ -3,20 +3,14 @@
EAPI=7
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-# (needed due to CMAKE_BUILD_TYPE != Gentoo)
-CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit cmake-utils git-r3 multilib-minimal multiprocessing pax-utils \
- python-any-r1 toolchain-funcs
+inherit cmake-utils llvm.org multilib-minimal multiprocessing \
+ pax-utils python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
-EGIT_BRANCH="release_90"
+LLVM_COMPONENTS=( llvm )
+llvm.org_set_globals
# Keep in sync with CMakeLists.txt
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430