summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-19.0.0_pre20240203.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-19.0.0_pre20240203.ebuild')
-rw-r--r--sys-devel/llvm/llvm-19.0.0_pre20240203.ebuild10
1 files changed, 0 insertions, 10 deletions
diff --git a/sys-devel/llvm/llvm-19.0.0_pre20240203.ebuild b/sys-devel/llvm/llvm-19.0.0_pre20240203.ebuild
index 23646ea90d8a..8ff126c7d4a1 100644
--- a/sys-devel/llvm/llvm-19.0.0_pre20240203.ebuild
+++ b/sys-devel/llvm/llvm-19.0.0_pre20240203.ebuild
@@ -446,16 +446,6 @@ multilib_src_configure() {
-DTerminfo_LIBRARIES=-lncurses
)
- # workaround BMI bug in gcc-7 (fixed in 7.4)
- # https://bugs.gentoo.org/649880
- # apply only to x86, https://bugs.gentoo.org/650506
- if tc-is-gcc && [[ ${MULTILIB_ABI_FLAG} == abi_x86* ]] &&
- [[ $(gcc-major-version) -eq 7 && $(gcc-minor-version) -lt 4 ]]
- then
- local CFLAGS="${CFLAGS} -mno-bmi"
- local CXXFLAGS="${CXXFLAGS} -mno-bmi"
- fi
-
# LLVM can have very high memory consumption while linking,
# exhausting the limit on 32-bit linker executable
use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"