summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-16.0.0_rc2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-16.0.0_rc2.ebuild')
-rw-r--r--sys-devel/llvm/llvm-16.0.0_rc2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-16.0.0_rc2.ebuild b/sys-devel/llvm/llvm-16.0.0_rc2.ebuild
index 21023c3bf7e4..92aec87031e0 100644
--- a/sys-devel/llvm/llvm-16.0.0_rc2.ebuild
+++ b/sys-devel/llvm/llvm-16.0.0_rc2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
inherit cmake llvm.org multilib-minimal pax-utils python-any-r1 \
- toolchain-funcs
+ toolchain-funcs flag-o-matic
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -325,6 +325,8 @@ get_distribution_components() {
}
multilib_src_configure() {
+ tcc-is-gcc && filter-lto # GCC miscompiles LLVM, bug #873670
+
local ffi_cflags ffi_ldflags
if use libffi; then
ffi_cflags=$($(tc-getPKG_CONFIG) --cflags-only-I libffi)