summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-11.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-11.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-11.0.0.9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-11.0.0.9999.ebuild b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
index e005e516f322..08addcf459df 100644
--- a/sys-devel/llvm/llvm-11.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
@@ -183,7 +183,9 @@ src_prepare() {
# manpages don't use markdown
if ! use doc; then
- sed -i -e '/source_parsers/d' docs/conf.py || die
+ sed -e "s:, 'recommonmark'::" \
+ -e '/markdown/d' \
+ -i docs/conf.py || die
fi
# Verify that the live ebuild is up-to-date
@@ -428,6 +430,10 @@ multilib_src_configure() {
local CXXFLAGS="${CXXFLAGS} -mno-bmi"
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake_src_configure