summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/files/10.0.1/0002-llvm-Disable-linking-llvm-exegesis-to-dylib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/files/10.0.1/0002-llvm-Disable-linking-llvm-exegesis-to-dylib.patch')
-rw-r--r--sys-devel/llvm/files/10.0.1/0002-llvm-Disable-linking-llvm-exegesis-to-dylib.patch29
1 files changed, 0 insertions, 29 deletions
diff --git a/sys-devel/llvm/files/10.0.1/0002-llvm-Disable-linking-llvm-exegesis-to-dylib.patch b/sys-devel/llvm/files/10.0.1/0002-llvm-Disable-linking-llvm-exegesis-to-dylib.patch
deleted file mode 100644
index 24786905c4d9..000000000000
--- a/sys-devel/llvm/files/10.0.1/0002-llvm-Disable-linking-llvm-exegesis-to-dylib.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 07b6fdcde1ed64043244965b97788a2b12af4d6d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 16 Jun 2020 12:31:36 +0200
-Subject: [PATCH 2/4] [llvm] Disable linking llvm-exegesis to dylib
-
-Force linking llvm-exegesis to static LLVM libraries instead of dylib
-to prevent duplicate symbols due to linking both. Ideally, we'd want
-to link to the dylib only here but the target sub-libraries use hidden
-symbols from LLVM target libraries and therefore linking the dylib
-fails.
----
- llvm/tools/llvm-exegesis/CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/llvm/tools/llvm-exegesis/CMakeLists.txt b/llvm/tools/llvm-exegesis/CMakeLists.txt
-index a59e1b74024..0575f2a06bb 100644
---- a/llvm/tools/llvm-exegesis/CMakeLists.txt
-+++ b/llvm/tools/llvm-exegesis/CMakeLists.txt
-@@ -5,6 +5,7 @@ set(LLVM_LINK_COMPONENTS
- )
-
- add_llvm_tool(llvm-exegesis
-+ DISABLE_LLVM_LINK_LLVM_DYLIB
- llvm-exegesis.cpp
- )
-
---
-2.27.0
-