summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild23
1 files changed, 6 insertions, 17 deletions
diff --git a/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild b/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild
index ae78e1164ce5..ba2ffc76a706 100644
--- a/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-9.0.1.9999.ebuild
@@ -3,14 +3,12 @@
EAPI=7
-inherit git-r3
+inherit llvm.org
DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
-EGIT_BRANCH="release_90"
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -19,19 +17,10 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' utils/vim
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
src_install() {
insinto /usr/share/vim/vimfiles
- doins -r utils/vim/*/
+ doins -r */
# some users may find it useful
- newdoc utils/vim/README README.vim
- dodoc utils/vim/vimrc
+ newdoc README README.vim
+ dodoc vimrc
}