summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 9fc57491538d..91c997c92c31 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -14,7 +14,6 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
-RPM=
MY_PV=${PV}
case ${PV} in
9999*)
@@ -98,8 +97,6 @@ pkg_setup() {
}
src_prepare() {
- [[ -n ${RPM} ]] && rpm_spec_epatch "${WORKDIR}"/gdb.spec
-
default
strip-linguas -u bfd/po opcodes/po
@@ -244,6 +241,10 @@ src_install() {
if [[ ${CHOST} == *-freebsd* ]]; then
rm "${ED}"/usr/bin/gcore || die
fi
+
+ if use python; then
+ python_optimize "${ED}"/usr/share/gdb/python/gdb
+ fi
}
pkg_postinst() {