summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-10.2.ebuild')
-rw-r--r--sys-devel/gdb/gdb-10.2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-devel/gdb/gdb-10.2.ebuild b/sys-devel/gdb/gdb-10.2.ebuild
index 9968e1b3e6af..bdb30edb1d9e 100644
--- a/sys-devel/gdb/gdb-10.2.ebuild
+++ b/sys-devel/gdb/gdb-10.2.ebuild
@@ -46,7 +46,7 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="cet lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
+IUSE="cet guile lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
"
@@ -65,6 +65,7 @@ RDEPEND="
sys-libs/zlib
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
+ guile? ( >=dev-scheme/guile-2.0 )
xml? ( dev-libs/expat )
source-highlight? (
dev-util/source-highlight
@@ -158,8 +159,6 @@ src_configure() {
--enable-64-bit-bfd
--disable-install-libbfd
--disable-install-libiberty
- # Disable guile for now as it requires guile-2.x #562902
- --without-guile
--enable-obsolete
# This only disables building in the readline subdir.
# For gdb itself, it'll use the system version.
@@ -177,6 +176,7 @@ src_configure() {
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPYTHON}")
$(use_with xxhash)
+ $(use_with guile)
)
if use sparc-solaris || use x86-solaris ; then
# disable largefile support