summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-11.2.1_pre9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-11.2.1_pre9999.ebuild')
-rw-r--r--sys-devel/gcc/gcc-11.2.1_pre9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-11.2.1_pre9999.ebuild b/sys-devel/gcc/gcc-11.2.1_pre9999.ebuild
new file mode 100644
index 000000000000..500dca96a088
--- /dev/null
+++ b/sys-devel/gcc/gcc-11.2.1_pre9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_GCC_VER="11.2.0"
+PATCH_VER="1"
+
+inherit toolchain
+
+# Don't keyword live ebuilds
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+
+RDEPEND=""
+BDEPEND="${CATEGORY}/binutils"
+
+src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
+ toolchain_src_prepare
+}