summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-10.2.0-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-10.2.0-r4.ebuild')
-rw-r--r--sys-devel/gcc/gcc-10.2.0-r4.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-10.2.0-r4.ebuild b/sys-devel/gcc/gcc-10.2.0-r4.ebuild
new file mode 100644
index 000000000000..1e1a7574abd6
--- /dev/null
+++ b/sys-devel/gcc/gcc-10.2.0-r4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_VER="5"
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=""
+BDEPEND="${CATEGORY}/binutils"
+
+src_prepare() {
+ has_version '>=sys-libs/glibc-2.32-r1' && rm -v "${WORKDIR}/patch/23_all_disable-riscv32-ABIs.patch"
+ toolchain_src_prepare
+}