summaryrefslogtreecommitdiff
path: root/sys-devel/clang/clang-9.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-9.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang/clang-9.0.0.9999.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/sys-devel/clang/clang-9.0.0.9999.ebuild b/sys-devel/clang/clang-9.0.0.9999.ebuild
index 4fac61d4c534..92eaa1de0a74 100644
--- a/sys-devel/clang/clang-9.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-9.0.0.9999.ebuild
@@ -63,12 +63,6 @@ S=${WORKDIR}/x/y/${P}
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=(
- # fix linking in non-native build (without tools-extra)
- # https://bugs.llvm.org/show_bug.cgi?id=43281
- "${FILESDIR}"/9.0.0/0001-clang-unittest-Import-LLVMTestingSupport-if-necessar.patch
-)
-
# Multilib notes:
# 1. ABI_* flags control ABIs libclang* is built for only.
# 2. clang is always capable of compiling code for all ABIs for enabled
@@ -114,6 +108,8 @@ multilib_src_configure() {
local clang_version=$(ver_cut 1-3 "${llvm_version}")
local mycmakeargs=(
+ # ensure that the correct llvm-config is used
+ -DLLVM_CONFIG="$(type -P "${CHOST}-llvm-config")"
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${SLOT}"
-DCMAKE_INSTALL_MANDIR="${EPREFIX}/usr/lib/llvm/${SLOT}/share/man"
# relative to bindir