summaryrefslogtreecommitdiff
path: root/sys-devel/clang/clang-5.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-5.0.9999.ebuild')
-rw-r--r--sys-devel/clang/clang-5.0.9999.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/sys-devel/clang/clang-5.0.9999.ebuild b/sys-devel/clang/clang-5.0.9999.ebuild
index 82cff8b91407..b8bfe4b8916a 100644
--- a/sys-devel/clang/clang-5.0.9999.ebuild
+++ b/sys-devel/clang/clang-5.0.9999.ebuild
@@ -62,6 +62,11 @@ S=${WORKDIR}/x/y/${P}
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=(
+ # fix finding compiler-rt libs
+ "${FILESDIR}"/5.0.0/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
+)
+
# Multilib notes:
# 1. ABI_* flags control ABIs libclang* is built for only.
# 2. clang is always capable of compiling code for all ABIs for enabled
@@ -101,19 +106,6 @@ src_unpack() {
git-r3_checkout "${EGIT_REPO_URI}" "${S}"
}
-src_prepare() {
- # fix finding compiler-rt libs
- eapply "${FILESDIR}"/5.0.0/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
-
- cd tools/extra || die
- # fix stand-alone test build for extra tools
- eapply "${FILESDIR}"/5.0.0/extra/0002-test-Fix-clang-library-dir-in-LD_LIBRARY_PATH-For-st.patch
- cd - >/dev/null || die
-
- # User patches
- eapply_user
-}
-
multilib_src_configure() {
local llvm_version=$(llvm-config --version) || die
local clang_version=$(ver_cut 1-3 "${llvm_version}")