summaryrefslogtreecommitdiff
path: root/sys-devel/clang/clang-10.0.1_rc1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-10.0.1_rc1.ebuild')
-rw-r--r--sys-devel/clang/clang-10.0.1_rc1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-10.0.1_rc1.ebuild b/sys-devel/clang/clang-10.0.1_rc1.ebuild
index db3798d217bd..ec2222153574 100644
--- a/sys-devel/clang/clang-10.0.1_rc1.ebuild
+++ b/sys-devel/clang/clang-10.0.1_rc1.ebuild
@@ -289,6 +289,10 @@ multilib_src_configure() {
)
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake_src_configure