summaryrefslogtreecommitdiff
path: root/sys-devel/clang/clang-10.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-10.0.0.ebuild')
-rw-r--r--sys-devel/clang/clang-10.0.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-devel/clang/clang-10.0.0.ebuild b/sys-devel/clang/clang-10.0.0.ebuild
index aae5ad123f05..a63fa6015ce5 100644
--- a/sys-devel/clang/clang-10.0.0.ebuild
+++ b/sys-devel/clang/clang-10.0.0.ebuild
@@ -34,7 +34,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux"
IUSE="debug default-compiler-rt default-libcxx doc +static-analyzer
test xml kernel_FreeBSD ${ALL_LLVM_TARGETS[*]}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -234,6 +234,10 @@ multilib_src_configure() {
)
fi
+ # LLVM can have very high memory consumption while linking,
+ # exhausting the limit on 32-bit linker executable
+ use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake-utils_src_configure