summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang-common/clang-common-16.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0.9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
index db83638be497..7fc966f60858 100644
--- a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
@@ -20,8 +20,11 @@ PDEPEND="
llvm-libunwind? ( sys-libs/llvm-libunwind )
!llvm-libunwind? ( sys-libs/libunwind )
)
+ !default-compiler-rt? ( sys-devel/gcc )
default-libcxx? ( >=sys-libs/libcxx-${PV} )
+ !default-libcxx? ( sys-devel/gcc )
default-lld? ( sys-devel/lld )
+ !default-lld? ( sys-devel/binutils )
"
LLVM_COMPONENTS=( clang/utils )
@@ -53,10 +56,6 @@ pkg_pretend() {
fi
}
-usec() {
- usex "default-${1}" "" "# "
-}
-
src_install() {
newbashcomp bash-autocomplete.sh clang
@@ -65,10 +64,10 @@ src_install() {
# This file is initially generated by sys-devel/clang-runtime.
# It is used to control the default runtimes using by clang.
- $(usec compiler-rt)-rtlib=compiler-rt
- $(usec compiler-rt)-unwindlib=libunwind
- $(usec libcxx)-stdlib=libc++
- $(usec lld)-fuse-ld=lld
+ --rtlib=$(usex default-compiler-rt compiler-rt libgcc)
+ --unwindlib=$(usex default-compiler-rt libunwind libgcc)
+ --stdlib=$(usex default-libcxx libc++ libstdc++)
+ -fuse-ld=$(usex default-lld lld bfd)
EOF
newins - gentoo-gcc-install.cfg <<-EOF