summaryrefslogtreecommitdiff
path: root/sys-devel/automake/automake-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-9999.ebuild')
-rw-r--r--sys-devel/automake/automake-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-devel/automake/automake-9999.ebuild b/sys-devel/automake/automake-9999.ebuild
index c483767b582d..1c06ea4470f4 100644
--- a/sys-devel/automake/automake-9999.ebuild
+++ b/sys-devel/automake/automake-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
inherit python-any-r1
@@ -49,7 +49,11 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/automake-1.16.1-py3-compile.patch
"${FILESDIR}"/automake-1.16.1-py3-no-pyo-files.patch
+ "${FILESDIR}"/automake-1.16.1-py3-pep3147.patch
+ "${FILESDIR}"/automake-1.16.1-py3-pep3147-cmdline.patch
+ "${FILESDIR}"/automake-1.16.1-py3-compile-test.patch
)
+# All patches have been submitted upstream.
pkg_setup() {
use test && python-any-r1_pkg_setup