summaryrefslogtreecommitdiff
path: root/sys-cluster/singularity
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest2
-rw-r--r--sys-cluster/singularity/singularity-3.8.1.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index ad831a1c2115..9785d9331de0 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,3 +1,5 @@
DIST singularity-3.8.0.tar.gz 7892955 BLAKE2B a75c9a5646cf5bfcc906bdda0e72e062787f6694322ca62ff329c63dfad051edc6c751e4e58cf01476a133947d87ad6230ba60e2d7b7da75ba654486a6c8d48c SHA512 b1e3dc673fbf58d8fa13bea4c67114d1abf0f17e86f1958f585795374107f6b18dd854899b4a574dc3e4d8d4abf4177c26e63c7c3436ae1d35c66331f1630272
+DIST singularity-3.8.1.tar.gz 7935330 BLAKE2B 112e04936086b5c068730f8ef52927f4c6c5257b5057828f80946e1a9a5fd83aa657ab55d55c270351835500ca9c0fccc22695cc0c3012d69f411f1b6c5152ab SHA512 7303f82c0ac821f30aab301eb7cb60bc3a56ccef3e21d881f2facc87805ac4b9cf9d776f502766512e91de59863e693189a7509296494fcf028f8453459758a8
EBUILD singularity-3.8.0.ebuild 1900 BLAKE2B a24c10ad485b5359a304caf1c85dcd1529e41d50070f842b9d36f1ef79c76edd51ed44f8bceddeea729038eb299e1a917036fef34f036413255033e3e4c0d3ae SHA512 32764eddc65b36a265c7527852b4b1709dca3f1cc17ad38ea75950fd2972643f0f13238df1e481fe392762ef6755e83707b64037b36f73dd18a923ee0f28058c
+EBUILD singularity-3.8.1.ebuild 1902 BLAKE2B 2eb0b09273480ac09f1ff9fbfc759046253660bba7c049b80890ea91ba78c4cf05b583ec4eb8db40450cdc1e06261fbced9c4f6d22cfe05ded82ec66c9eb4206 SHA512 e9a894fc5313729fa28c4353cf4b0ca298a2aeb9ebeaaa67b03a9aa0cf90e7c8e39fd7effd6f8f50c5f85e1d0ba60be77a2d4f58b881d2ffc75c20f6956f0982
MISC metadata.xml 451 BLAKE2B 0cca32721561e4100348cd884b88edad067a426736df27d4be6926525f9dd1315387dbefff84b983e69ab1972a44cd3a3a2c643bae676b413dab3482005d4ceb SHA512 da6f640f7df71bfe98fdabfe8ea69b1929b80b3c23d869dc496515a76d3f76c5d89d38843faf850184ddd7f624dd1e821dd50103f92e81aeb620a4bcd7151609
diff --git a/sys-cluster/singularity/singularity-3.8.1.ebuild b/sys-cluster/singularity/singularity-3.8.1.ebuild
new file mode 100644
index 000000000000..2c112879880a
--- /dev/null
+++ b/sys-cluster/singularity/singularity-3.8.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="https://sylabs.io"
+SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network +suid"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+COMMON="sys-libs/libseccomp"
+BDEPEND="virtual/pkgconfig"
+DEPEND="${COMMON}
+ >=dev-lang/go-1.13.0
+ app-crypt/gpgme
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup"
+RDEPEND="${COMMON}
+ sys-fs/squashfs-tools"
+
+CONFIG_CHECK="~SQUASHFS"
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --runstatedir=/run \
+ --localstatedir=/var \
+ $(usex network "" "--without-network") \
+ $(usex suid "" "--without-suid")
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C builddir install
+ keepdir /var/singularity/mnt/session
+
+ # As of version 3.5.3 this seems to be very much broken, affecting
+ # commands which have got nothing to do with singularity (example:
+ # completion on 'udisks mount -b /dev/' rejects all files from that
+ # directory other than 'autofs'). Moreover, this should go into
+ # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
+ # Hopefully temporary, which is why we delete this at install time
+ # instead of patching build scripts not to generate bash-completion
+ # data in the first place.
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
+ if use examples; then
+ dodoc -r examples
+ fi
+}