summaryrefslogtreecommitdiff
path: root/sys-cluster/rdma-core/rdma-core-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/rdma-core/rdma-core-9999.ebuild')
-rw-r--r--sys-cluster/rdma-core/rdma-core-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-9999.ebuild b/sys-cluster/rdma-core/rdma-core-9999.ebuild
index b4c7cd19350a..19fe7450ce77 100644
--- a/sys-cluster/rdma-core/rdma-core-9999.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake perl-functions python-single-r1 udev systemd
@@ -15,17 +15,18 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
else
SRC_URI="https://github.com/linux-rdma/rdma-core/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
SLOT="0"
-IUSE="neigh python static-libs systemd valgrind"
+IUSE="lttng neigh python static-libs systemd valgrind"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
COMMON_DEPEND="
- dev-lang/perl
+ dev-lang/perl:=
virtual/libudev:=
+ lttng? ( dev-util/lttng-ust:= )
neigh? ( dev-libs/libnl:3 )
systemd? ( sys-apps/systemd:= )
valgrind? ( dev-util/valgrind )
@@ -77,6 +78,7 @@ src_configure() {
-DCMAKE_INSTALL_UDEV_RULESDIR="${EPREFIX}$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
-DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex !systemd)"
+ -DENABLE_LTTNG="$(usex lttng)"
-DENABLE_VALGRIND="$(usex valgrind)"
-DENABLE_RESOLVE_NEIGH="$(usex neigh)"
-DENABLE_STATIC="$(usex static-libs)"