summaryrefslogtreecommitdiff
path: root/sys-cluster/rdma-core/rdma-core-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/rdma-core/rdma-core-9999.ebuild')
-rw-r--r--sys-cluster/rdma-core/rdma-core-9999.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-9999.ebuild b/sys-cluster/rdma-core/rdma-core-9999.ebuild
index 29eafd00fa1c..b4c7cd19350a 100644
--- a/sys-cluster/rdma-core/rdma-core-9999.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit cmake perl-functions python-single-r1 udev systemd
@@ -29,13 +29,16 @@ COMMON_DEPEND="
neigh? ( dev-libs/libnl:3 )
systemd? ( sys-apps/systemd:= )
valgrind? ( dev-util/valgrind )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${COMMON_DEPEND}
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${COMMON_DEPEND}
python? (
$(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
+ <dev-python/cython-3[${PYTHON_USEDEP}]
')
- )"
+ )
+"
RDEPEND="${COMMON_DEPEND}
!sys-fabric/infiniband-diags
!sys-fabric/libibverbs
@@ -51,16 +54,21 @@ RDEPEND="${COMMON_DEPEND}
!sys-fabric/libmlx4
!sys-fabric/libmlx5
!sys-fabric/libocrdma
- !sys-fabric/libnes"
+ !sys-fabric/libnes
+"
# python is required unconditionally at build-time
BDEPEND="
${PYTHON_DEPS}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
-PATCHES=( "${FILESDIR}"/${PN}-39.0-RDMA_BuildType.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-39.0-RDMA_BuildType.patch
+)
src_configure() {
perl_set_version
+
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
-DCMAKE_INSTALL_RUNDIR=/run